scorpion21c
?>

Составить программу в pascal 1)в строке , введенной с клавиатуры , все буквы и заменить на % 2)из строки, введенной с клавиатуры , удалить все символы , начиная с середины.

Информатика

Ответы

info32
1) var s: string; i: longint; begin read(s); for i: =1 to length(s) do   if s[i]='и' then s[i]: ='%'; writeln(s); end. 2) var s: string; l: longint; begin read(s); l: =length(s); delete(s, (l div 2)+1, l-(l div 2)); writeln(s); end.
Margarita

pascalabc.net

begin

  var p : = readinteger('p =');

  var a : = arrrandom(p, -99, 99);

  a.println;

  var q : = a.findindex(r -> r < 0);

  if q > -1 then

  begin

    var b : = a? [: q].where(r -> r.iseven).toarray;

    print('первый массив: ');

    b.println;

    var c : = a? [q: ].where(r -> r.isodd).toarray;

    print('второй массив: ');

    c.println;

  end

  else

    println('в массиве нет отрицательных элементов')

end.

Blekjek730

Объяснение: реальной жизни существует множество ситуаций с различными вероятностями. Например, если у монеты одна сторона тяжелей другой, то при ее бросании вероятность выпадения «орла» и «решки» будет различной.

 

Сначала разберемся с понятием «вероятность». Введем следующие понятия:

испытание - любой эксперимент;

 

единичное испытание - испытание, в котором совершается одно действие с одним предметом (например, подбрасывается монетка, или из корзины извлекается шар);

 

исходы испытаний - результаты испытания (например, при подбрасывании монеты выпал «орел», или из корзины извлекли белый шар);

множество исходов испытания - множество всех возможных исходов испытания;

 

случайное событие - событие, которое может произойти или не произойти (например, выигрыш билета в лотерее, извлечение карты определенной масти из колоды карт).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в pascal 1)в строке , введенной с клавиатуры , все буквы и заменить на % 2)из строки, введенной с клавиатуры , удалить все символы , начиная с середины.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

antoha512
Vik1744184
avdeevau807
milenaochirova01017424
sandovo590
Chausmonk4
jaksonj326
aedunova3
Peshkov
pnat1235
a800000
zalev
Станиславович ыфвыв
Волков1968
kot271104