D.Yu. Polina1703
?>

100 .напишите программу перевода числа из восьмеричной системы счисления в двоичную. оформить в паскале.

Информатика

Ответы

lk1303
Предполагается, что восьмеричное число записано, как символьная строка, поскольку максимальная разрядность не была оговорена в . const   m: array['0'..'7'] of string=           ('000','001','010','011','100','101','110','111');   m1: array['1'..'7'] of string=           ('1','10','11','100','101','110','111'); var   s8,s2: string;   i: integer; begin   write('введите восьмеричное число: '); readln(s8);   s2: =m1[s8[1]];   for i: =2 to length(s8) do s2: =s2+m[s8[i]];   writeln('в двоичной системе: ',s2) end. тестовое решение: введите восьмеричное число: 360721 в двоичной системе: 11110000111010001
stanefimov
Uses crt; var dd,mm,gg: integer; begin readln(dd,mm,gg); case dd of 1..5: writeln('начало'); 6..14: writeln('первая половина'); 15: writeln('середина'); 16..25: writeln('вторая половина'); 26..31: writeln('конец'); end; case mm of 1:   writeln('января'); 2:   writeln('февраля'); 3:   writeln('марта'); 4:   writeln('апреля'); 5:   writeln('мая'); 6:   writeln('июня'); 7:   writeln('июля'); 8:   writeln('августа'); 9:   writeln('сентября'); 10:   writeln('октября'); 11:   writeln('ноября'); 12:   writeln('декабря'); end; if gg mod 4=0 then writeln ('високосный') else writeln('не високосный'); end. var a: integer; begin readln(a); writeln(a mod 10,a); end.
Nertman45

АБВГ

Объяснение:

1. Переведем символы в логические операции:

А Рататуй или Рапунцель или Зверополис

Б (Рататуй и Рапунцель) или Зверополис

В Рататуй и Рапунцель

Г Рататуй и Рапунцель и Зверополис

2. Наибольшее количество страниц будет при за с "или", так как

операция "и" "ограничивает" поиск, то есть при поиске "Рататуй ИЛИ Рапунцель" мы будем видеть следующие страницы:

-Рататуй

-Рапунцель

-Рататуй и Рапунцель,

а при поиске "Рататуй И Рапунцель" появятся следующие результаты:

-Рататуй и Рапунцель.

Таким образом, наибольшее число страниц мы получим при за А: Рататуй | Рапунцель | Зверополис, наименьшее - Г: Рататуй & Рапунцель & Зверополис.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

100 .напишите программу перевода числа из восьмеричной системы счисления в двоичную. оформить в паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kati2005
sergeevich
Nataliyaof
dashafox8739
Сергеевна-Иван1045
mira15963256
igraparkGP51
titovass9
Рафаэль633
Акоповна
ikalabuhova
Nadegdasb
tyrenumberone
gk230650
Panei
▲