Elshel8694
?>

Паскаль: 41 - циклы с условием 1. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =1; while i< = do begin writeln('! '); i: =i+1; end; ответ: введите число 2. сколько раз будет выполнен этот цикл? i: =5; while i< 5 do begin writeln('! '); i: =i+1; end; ответ: введите число 3. какое число будет выведено на экран в результате выполнения этого цикла? i: =6; write('9'); while i< 5 do begin write(i); i: =i+1; end; ответ: введите строку 4. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =3; while i> = do begin writeln('! '); i: =i-1; end; ответ: введите число 5. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =; while i> =3 do begin writeln('! '); i: =i-1; end; ответ: введите число 6. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза? i: =; while i< =9 do begin writeln('! '); i: =i+1; end; ответ: введите число 7. чему будет равно значение переменной «a» после выполнения этого цикла? i: =3; a: =12; while i< 3 do begin a: =a+i; i: =i+1; end; ответ:

Информатика

Ответы

andreu420082132
      запишем вычисление суммы "в столбик", помня, что вычисления проводятся в системе счисления по некоторому основанию n> 7. почему именно n> 7? потому, что если бы основание системы было равно или меньше семи, в записи числа цифра семь не могла бы существовать.     12 + 17     31       в младшем разряде 2+7=1, чего быть не может, следовательно, 2+7=11 и единица пошла в старший разряд. подтверждение этому мы видим при сложении в старшем разряде: 1+1+1=3 (учтена единица от переноса).       мы знаем, что 2+7=9 в десятичной системе счисления, а у нас получилось 11. находим разницу: 11-9=2. именно на столько основание системы счисления меньше десяти. 10-2=8. следовательно, система счисления восьмеричная. ответ: в восьмеричной системе счисления.
apetrov54
Cls n = 0 for i = 1 to 9     for j = 0 to 9           for k = 0 to 9                 c1 = i < > j and i < > k and j < > k                 if c1 then c1 = (i + j + k) mod 7 = 0                 if c1 then c1 = (100 * i + 10 * j + k) mod 7 = 0                 if c1 then                       print i; j; k                       n = n + 1                 end if           next k     next j next i if n = 0 then print "нет решения" тестовое решение:   3  2  9   3  9  2   5  1  8   5  8  1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль: 41 - циклы с условием 1. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =1; while i< = do begin writeln('! '); i: =i+1; end; ответ: введите число 2. сколько раз будет выполнен этот цикл? i: =5; while i< 5 do begin writeln('! '); i: =i+1; end; ответ: введите число 3. какое число будет выведено на экран в результате выполнения этого цикла? i: =6; write('9'); while i< 5 do begin write(i); i: =i+1; end; ответ: введите строку 4. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =3; while i> = do begin writeln('! '); i: =i-1; end; ответ: введите число 5. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза? i: =; while i> =3 do begin writeln('! '); i: =i-1; end; ответ: введите число 6. какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза? i: =; while i< =9 do begin writeln('! '); i: =i+1; end; ответ: введите число 7. чему будет равно значение переменной «a» после выполнения этого цикла? i: =3; a: =12; while i< 3 do begin a: =a+i; i: =i+1; end; ответ:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

testovvanya
Елена_Зайкин1665
moskvabelarus
bike-garage8
enot1975
Головин662
mrFuz
игнатова_Сергей1228
ukkavtodor6
Dmitrievich-Telishev
vikgor45
Yekaterina Oksyuta1657
bezzfamilny631
Wlad967857
fil-vasilij90