Dmitrievich-Telishev
?>

Составить программу, которая считывает 2 числа. Записывает их в переменные А и В. Далее Меняет местами значения переменных А и В используя третью переменную С. Результат выводит на экран.

Информатика

Ответы

Штакина1568

a = int(input('a = '))

b = int(input('b = '))

a = a + b

b = a - b

a = a - b

print('a =', a)

print('b =', b)

Galliardt Sergeevna1284
Изучать информатику я начала в 5 классе. Это очень интересный предмет. Учитель объясняет нам как работать с программами , бережно относиться к компьютеру , правила безопасности. В первую очередь надо уметь работать за компьютером. Правильно сидеть, не садиться за компьютер с мокрыми руками, делать гимнастику и разминку, для спины и глаз. Возможно, когда нибудь я свяжу свою жизнь с информатикой. В наше время программист очень востребованная профессия. Им платят большие деньги. Но, очень ухудшается здоровье. От долгого времени проведенного за компьютером болит спина, искривляется позвоночник и садится зрение. Надо делать все в меру. И когда нибудь я стану гуру-информатики.  
annanudehead1426
//Раз на первый вопрос господина Alviko Вы не ответили, буду считать что количество столбцов и строк уже задано.
//Pascal ABC.NET v3.1 сборка 1172

Const
n=3; //количество строк
m=4; //количество столбцов

Var
 f:text;
 ma:array[1..n,1..m] of integer;
 i,j,s:integer;
begin
 assign(f,'matrix.txt');
 reset(f);
 for i:=1 to n do
 begin
  for j:=1 to m do
   begin
   read(f,ma[i,j]);
   s:=s+ma[i,j];
   end;
 end;
 close(f);
 for i:=1 to n do
 begin
  writeln;
  for j:=1 to m do
   write(ma[i,j]:4);
 end;
 writeln;
 write(s);
end.

matrix.txt:
1 2 3 4
4 5 6 4
7 8 9 4
Вывод программы:

   1   2   3   4
   4   5   6   4
   7   8   9   4
57

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая считывает 2 числа. Записывает их в переменные А и В. Далее Меняет местами значения переменных А и В используя третью переменную С. Результат выводит на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yugraspets
ag-modul
Александра Викторович531
Stanislavovna1237
Dimston134877
Ruzalina_Svetlana1435
zbellatriks
dkedrin74038
nikitavertiev98400
elenak26038778
jim2k
Serkova_Elena251
jeep75
alfastore4
Оксана170