var i, j, a, b: integer; s: real; begin write('Введите a: '); readln(a); write('Введите b: '); readln(b); for i := a to b do if (i mod 3) = 0 then begin s := s + i; inc(j); end; s := s / j; writeln('ответ: ', s); end.
klodialeit36
18.07.2022
// PascalABC.Net 3.0, сборка 1064 const n = 10; var ms: array[1..n] of string; t: string; i, j: integer; f: Text; begin { Чтение матрицы из файла } Assign(f, 'in.txt'); Reset(f); for i := 1 to n do Readln(f, ms[i]); Close(f); { Вывод матрицы на экран } Writeln('*** Бинарная матрица ***'); for i := 1 to n do Writeln(ms[i]); { Сортировка обменом (простейшая) } for i := 1 to n - 1 do for j := 1 to n - 1 do if ms[j] > ms[j + 1] then begin t := ms[j]; ms[j] := ms[j + 1]; ms[j + 1] := t end; { Поиск одинаковых строк } Writeln('Совпадающие строки'); j := 1; t := ms[1]; for i := 2 to n do begin if ms[i] = t then Inc(j) else begin if j > 1 then begin Writeln(t); j := 1 end; t := ms[i] end end; if j > 1 then Writeln(t) end.
1) Если x^3 < 10, то (x+1)^3 > 20. Это верно при x = 2. 2^3 < 10, 3^3 > 20 2) Если x(x+1) > 10, то (x+1)(x+2) < 10. Это верно при x = -4 (-4)(-3) = 12 > 10; (-3)(-2) = 6 < 10 Но при x = 2 будет ложная посылка (2*3 > 10 - это ложно), из которой следует ложный вывод 3*4 < 10. Поэтому импликация верна. ответ x = 2 3) Если x(x+1)(x+2) > 25, то x < x-1 Это сложнее. x < x-1 - ложно при любом х. Импликация будет истинной, только если посылка ложная. x(x+1)(x+2) > 25 - должно быть ложно. Это при x = 2. x(x+1)(x+2) = 2*3*4 = 24.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу. даны 2 числа a и b. найти среднее арифметическое всех чисел кратных 3 из интервала [a, b].
i, j, a, b: integer;
s: real;
begin
write('Введите a: '); readln(a);
write('Введите b: '); readln(b);
for i := a to b do
if (i mod 3) = 0 then
begin
s := s + i;
inc(j);
end;
s := s / j;
writeln('ответ: ', s);
end.