chaa140
?>

Составить , которую можно решить с цикла предусловия и соответственно написать программу в паскале.

Информатика

Ответы

macmakka
Написать программу, которая выводит на экран сумму ряда
\frac{945}{9} - \frac{927}{33} + \frac{909}{507} - ...+ \frac{27}{1233}

пусть a – числитель; b – знаменатель; da и db – шаг для числителя и знаменателя; n  -  для смены знака;    
Программа:
const
da=  -18; {927-945}
db= 24;   {33-9}
var a,b,n: integer;
s: real;
     begin
         s:=0; n:=1; a:=945;b:=9;      
             while a>=27 do      
                   begin      
                         s:=s+a/b*n;    {подсчет суммы}      
                         a:=a+da;      
                         b:=b+db;      
                         n:= -1*n;        {изменение знака}        
                  end;
writeln('s=',s:4:2);
end.
andrey00713

#include <iostream>

using namespace std;

int main ()

{

   setlocale(0, "");

   int i = 0; // инициализируем счетчик цикла.

   int sum = 0; // инициализируем счетчик суммы.

   do {// выполняем цикл.

       i++;

       sum += i;

   } while (i < 1000); // пока выполняется условие.

   cout << "Сумма чисел от 1 до 1000 = " << sum << endl;

   return 0;

}

Объяснение:

Цикл do while

Цикл do while очень похож на цикл while. Единственное их различие в том, что при выполнении цикла do while один проход цикла будет выполнен независимо от условия. Решение задачи на поиск суммы чисел от 1 до 1000, с применением цикла do while.

Принципиального отличия нет, но если присвоить переменной i значение, большее, чем 1000, то цикл все равно выполнит хотя бы один проход.

lescha-77766

from builtins import print

a = int(input())

b = int(input())

c = int(input())

d = int(input())

if (a + b + c + d) == (a * b * c * d):

  print('Сумма и произведения равны')

else:

  if (a + b + c + d) < (a * b * c * d):

      print('Cумма меньше произведения')

  else:

      print('Сумма больше произведения')

#2

sum = 0

for i in range(4):

  a = int(input())

  if a > 0:

      sum+=a

print(sum)

# 3

sum = 0

for i in range(4):

  a = int(input())

  if a < 0:

      sum += a

print(sum)

# 4

minus = 0

plus = 0

null = 0

for i in range(4):

  a = int(input())

  if a < 0:

      minus += 1

  else:

      if a > 0:

          plus += 1

      else:

          null += 1

print('Положительных {}, отрицательных {}, нулей {}'.format(plus, minus, null))

# 5

a = int(input())

b = int(input())

polusum = (a * b) / 2

ydvoen = 2 * a * b

if a > b:

  a = polusum

  b = ydvoen

else:

  b = polusum

  a = ydvoen

print(a, b)

# 6

z = []

for i in range(3):

  z.append(input())

if z[0] == min(z):

  z[0] = 0

else:

  if z[1] == min(z):

      z[1] = 0

  else:

      z[2] = 0

print(z)

#7

z = []

for i in range(4):

  z.append(int(input()))

print(max(z)-min(z))

# 8

M = 0

kvartal = 0

M = int(input())

if (M > 1) and (M < 4):

  kvartal = 1

  print('Квартал - ', kvartal)

else:

  if (M > 3) and (M < 7):

      kvartal = 2

      print('Квартал - ', kvartal)

  else:

      if (M > 6) and (M < 10):

          kvartal = 3

          print('Квартал - ', kvartal)

      else:

          if (M > 9) and (M < 13):

              kvartal = 4

              print('Квартал - ', kvartal)

if kvartal == 0:

  print('Введён неккоректный месяц')

# 9

list = ['крыса', 'корова', 'тигр', 'заяц', 'дракон', 'змея', 'лошадь', 'овца', 'обезьяна', 'петух', 'собака', 'свинья']

god = int(input())

opred = (god - 1995) % 12 - 1

print(list[opred])

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить , которую можно решить с цикла предусловия и соответственно написать программу в паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

magazin7452834
cimora-kativ
Nikishina
dushechkin2
kriapex
irohmichaelchikaodiri
ann328389
Romanovich1658
Svetlana
natanikulina1735
yulyatmb
dp199088206
Ulianev77
nsoro937
andrewa