Жуков219
?>

Напишите программу, которая на отрезке a до b выводит на экран все числа, оканчивающихся нулем.

Информатика

Ответы

emilbadalov
Вот нужный тебе фрагмент кода
for i = a to b do
   if i mod 10 == 0  then
       write(i)

правда я не помню, в паскале нужно писать либо =, либо ==
Shteinbakh
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
function
Transpose(a: array[,] of integer): array[,] of integer;
//Поворот на 90гр по часовой стрелке
begin
  var m := Length(a, 0);
  var n := Length(a, 1);
  Result := new integer[n, m];
  for var i := 0 to n-1 do begin
    for var j := 0 to m-1 do
      Result[i, j] := a[m-1-j, i];
  end;
end;

begin
  var n := ReadInteger('Введите n:');
//Заполнение матрицы NxN сл. числами и вывод на экран
  var a :=MatrixRandom(n, n);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(a[i,j]);
    println;
    end;
     println;

  Println('поворот влево на 90 гр');
  var b := Transpose(a);
  b:=Transpose(b);
  b:=Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
  println;

  Println('поворот вправо на 90гр');
  b := Transpose(a);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
 println;

 Println('поворот на 180 гр');
  b := Transpose(a);
  b := Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
end.
Iselickaya1890

По своему назначению компьютер - это универсальный прибор для работы с информацией. По принципам своего устройства компьютер - это модель человека, работающего с информацией.Персональный компьютер (ПК) — это компьютер, предназначенный для обслуживания одного рабочего места. По своим характеристикам он может отличаться от больших ЭВМ, но функционально выполнять аналогичные операции. По эксплуатации различают настольные (desktop), портативные (laptop и notebook) и карманные (palmtop) модели ПК.Аппаратное обеспечение. Поскольку компьютер предоставляет все три класса информационных методов для работы с данными (аппаратные, программные и естественные), принято говорить о компьютерной системе как о состоящей из аппаратных и программных средств, работающих совместно. Узлы, составляющие аппаратные средства компьютера, называют аппаратным обеспечением. Они выполняют всю физическую работу с данными: регистрацию, хранение, транспортировку и преобразование как по форме, так и по содержанию, а также представляют их в виде, удобном для взаимодействия с естественными информационными методами человека.Программное обеспечение. Программы могут находиться в двух состояниях: активном и пассивном. В пассивном состоянии программа не работает и выглядит как данные, содержательная часть которых - сведения. В этом состоянии содержимое программы можно «читать» с других программ, как читают книги, и изменять. Из него можно узнать назначение программы и принцип ее работы. В пассивном состоянии программы создаются, редактируются, хранятся и транспортируются. Процесс создания и редактирования программ называется программированием.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая на отрезке a до b выводит на экран все числа, оканчивающихся нулем.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gelena03
anovikovsr
sandovo590
nunabat457
sn009
ganzashop
e-s-i-k
aci2003
tarhan1221
ksenia15-79
annademidova-74
ekasatkina
Bogataya Vladimir318
menesmir
tcmir