milkline-nn
?>

Посоны крч читайте составить программу, вычисляющую произведение 5 чисел записанных в файле (это надо делать в паскале накалякайте кто нить)

Информатика

Ответы

Valerevna-Vardan
Var     a, b, c, d, e : longint;
begin   
assign(input, 'D:\Vanya\School\Pascal\Input\input.txt');  reset(input);    assign(output, 'D:\Vanya\School\Pascal\Output\output.txt');  rewrite(output);    read(a,b,c,d,e);  write(a * b *c*d*e);
end.
Васильевичь Виктория457

Этап 1

1. Разработка концепции:

возраст пользователя.

вид игры: развлекающая, развивающая, обучающая, комплексная.

2. Разработка адресных требований к игре:

к сценарию.

к игровой среде.

к графике игры.

3. Написание сценария:

создание сюжетной канвы с определением персонажей игры.

прописывание диалогов.

внесение в канву сценария игровых моментов (развлекающих, обучающих, развивающих).

прописывание речёвок и моментов ожидания действий пользователя.

проверка сценария на: удобство управления игрой, удобство перемещения в игровом поле, соответствие концепции и требованиям к данной игре; взаимное соответствие элементов сценария друг другу.

4. Разработка технических требований к игре и подготовка тех.задания.

5. Взаимодействие с разработчиками технической части игры:

передача сценария в разработку.

разработка визуальных образов персонажей и фонов игры.

стыковка пожеланий заказчика игры с возможностями разработчиков по организации игрового Озвучка персонажей, если в игре имеются говорящие персонажи.

6. Тестовая версия игры.

7. Подготовка второго этапа - итоги предварительной работы, обобщение опыта, план работы по доработке игры.

Tanyamitia

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Посоны крч читайте составить программу, вычисляющую произведение 5 чисел записанных в файле (это надо делать в паскале накалякайте кто нить)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yocrew13
VadimovnaIgor
modos201276
annodomini1
porotikova1004
Semenova
nat63nesnova5
SitnikovYurii5
lzelenyi5
Yevgenii_Gurtovaya1532
Lyubov214
Герасимова107
nv6634
narkimry134
adminkuncevo