Vitalevich
?>

Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. напишите программу, которая позволит вывести все такие числа. в паскале

Информатика

Ответы

dima0218687
Var a,b,c,d,e:integer;
begin
for a:=1000 to 9999 do begin
e:=a;
b:= e mod 10;
e:= e div 10;  
c:= e mod 10;
e:= e div 10;  
d:= e mod 10;
e:= e div 10;   
if (b+d)=(c+e) then writeln(a);
end;
end.
yorestov

Объяснение:

Логотип – це графічний символ бренду. Здебільшого, це малюнок, наповнений різними кольорами й символами, з до якого спеціалісти створюють образ, що характеризує діяльність компанії, її товари та послуги. Логотип потрібен також для того, щоб люди могли впізнати поставщика товарів та послуг. Компаніям логотип потрібен для того, щоб виділятися серед конкурентів і мати якусь свою особливість. Зазвичай, логотип організації розміщується на головній сторінці її офіційного сайту. Логотипи можуть бути символічними, текстовими, комбінованими, буквенно-цифровими та у вигляді емблем. Крім того, логотипи відрізняються за формою. Вони можуть бути круглими, трикутними, квадратними, кривими і т.д. Стилістика зображення – це вже задача дизайнера. Логотип повинен бути довговічним, унікальним, універсальним та добре запам’ятовуватися.

kogakinoa
Var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>-2.4) and (x<5.7) then f:=sqr(x)
  else f:=4;
  Writeln('F=',f)
end.

var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>0.2) and (x<0.9) then f:=sin(x)
  else f:=1;
  Writeln('F=',f)
end.

var
  a,b,c:real;
begin
  Write('Введите три числа: '); Readln(a,b,c);
  Write('Условие ',a,'<',b,'<',c);
  if (b>a) and (b<c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.');
  Write('Условие ',b,'>',a,'>',c);
  if (a<b) and (a>c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.')
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. напишите программу, которая позволит вывести все такие числа. в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

larisau41
uzunanna19922488
Александра_Наталья1417
kristinmk
Yekaterina_Popova1413
Romanovna-yana
fox-cab3444
eutenkova805
bogdanovaoksa
kapral1812
Хасанбиевич Колесников716
Знайдіть % витрат та поясніть свої дії
Мусаев Игоревич371
Yurevich1243
shilinmikhaillg
seymurxalafov05