.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
long sum = 0;
int a;
cout << "Введите a" << endl;
cin >> a;
if (a > 500)
{
cout << "а > 500" << endl;
}
else
{
sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
cout << sum;
}
}
2.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
double average = (1 + 1000) / 2.;
cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;
}
3
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, b = 0;
cout << "Введите границы диапазона" << endl;
cin >> a >> b;
cout << "Все числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
cout << i << endl;
}
}
else
{
for (int i = b; i < a; i++)
{
cout << i << endl;
}
}
cout << "Чётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
cout << "Нечётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
cout << "Числа, кратные 7:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
}
4.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, sum = 0;
cout << "Введите числа" << endl;
while (true)
{
cin >> a;
if (a == 0)
{
break;
}
sum += a;
}
cout << "Сумма =" << sum << endl;
ответ:Для расчёта информационного объёма растрового графического изображения (V) используем формулу: V = i * k, где i – глубина цвета - количество битов, требуемое для кодирования цвета пикселя; k – это количество этих пикселей (точек) в изображении, определяющееся разрешающей соответствующего устройства компьютера, в данном случае – сканера.
Разрешающая сканера – 256 (28) точек на дюйм. 1 дюйм = 2,54 см.
Переведём см в дюймы: 12,7/2,54 = 5 д.; 10,16/2,54 = 4 д.
Находим количество пикселей (k), умножая и горизонталь, и вертикаль на разрешающую сканера: 5 * 256 * 4 * 256
Чтобы не пользоваться калькулятором, представим все возможные множители в степенях числа 2: 5 * 2⁸ * 2² * 2⁸ = 5 * 2¹⁸ (пикселей)
i = 16 = 2⁴ бит (глубина цвета)
Помним, что 1 байт = 8 бит = 2³ бит; 1 Кбайт = 1024 байта = 2¹⁰ байт = 2¹³бит; 1 Мбайт = 1024 Кбайта = 2¹⁰ Кбайт = 2²⁰ байт = 2²³ бит
Считаем V или I, кто как пишет:
V = 2⁴ * 5 * 2¹⁸ = 5 *2²² бит/2²³ = 5 * 2⁻¹ Мбайт = 5 * 0,5 = 2,5 Мбайт (ответ)
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Программа по информатике. дана масса яблок в ящике, которые надо разложить по пакетам по 3 кг в каждый. напишите программу, которая вычислит, сколько пакетов получится и сколько килограммов яблок останется. результат выведите на экран.
Program Zadacha;
Var pak, mas: real;
Begin
Writeln('Введите массу яблок');
Readln(mas); pak:=mas/3;
Writeln('Необходимо ',pak:4:2,' пакетов');
End.