docvet4
?>

составить программу, которая в каждом столбце двумерного массива случайных чисел находит наименьший элемент и записывает его индекс в одномерный массив.

Информатика

Ответы

zuzazuza61
Const
n=10;m=8;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of integer;
i,j,min:integer;
  begin
      for i:=1 to n do
         begin
             writeln;
                  for j:=1 to m do
                      begin
                          a[i,j]:=random(100);
                          write(a[i,j]:4);
                      end;
           end;
writeln;
for j:=1 to m do
   begin
       min:=a[i,1];
           for i:=1 to n do
                    if a[i,j]<min then
                         min:=a[i,j];
          b[j]:=min;
     end;
for i:=1 to m do
   write(b[i]:4);
end.
Shipoopi8

70, 35, 43, 132, 121, 11, 60, 64, 24, 31

Объяснение:

1) Изначально s = 0, затем на каждой из 12 – 6 + 1 = 7 итераций к ней прибавляется 10, итого получится 70

2) Аналогично, s = 0 + 7 * (8 – 3) = 35

3) Итерация с i = 1: k = 2 * 4 + 1 = 9. Итерация с i = 2: k = 2 * 9 + 2 = 20. Итерация с i = 3: k = 2 * 20 + 3 = 43.

4) s = 0 + 12 * 11 = 132  

5) s = 0 + 11 * (12 – 1) = 121

6) u = 26 – 1 – 2 – 3 – 4 – 5 = 11

7) s = 4 + 5 + … + 11 = 60

8) s = 1 * 2 * 2 * … * 2 (8 – 3 + 1 раз) = 64

9) y = 0 + 4 * 1 + 4 * 2 + 4 * 3 = 24

10) s = 3 + 2 * 2 + 2 * 3 + 2 * 4 + 2 * 5 = 31

kolefe22171

ответ:вот Живо́тные (лат. Animalia) — традиционно (со времён Аристотеля) выделяемая категория организмов, в настоящее время рассматривается в качестве биологического царства. Животные являются основным объектом изучения зоологии.

Животные относятся к эукариотам (в клетках имеются ядра). Классическими признаками животных считаются: гетеротрофность (питание готовыми органическими соединениями) и активно передвигаться. Впрочем, существует немало животных, ведущих неподвижный образ жизни, а гетеротрофность свойственна грибам и некоторым растениям-паразитам.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составить программу, которая в каждом столбце двумерного массива случайных чисел находит наименьший элемент и записывает его индекс в одномерный массив.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

соловьев_Куркина
skalegin68
vyborovvs
Gulyaev_Egorkina
perovd8111
plio67380
алексей-Ветошкин
balabinatanya7174
mikhail
kisuhakisa
mrilyushchenko6
АртакСергеевич1723
sinicin80
Mikhailovna1444
Shishkinaanasta1997