Бернард pokerman
?>

1)дан массив, состоящий из целых чисел. найдите минимальный элемент и индекс. 2)дан массив, состоящий из целых чисел. найдите максимальный элемент в массиве.

Информатика

Ответы

lemoh
1 ctrl+shift+alt ну как то так мне такое уже давали и зделал на 10
KonovalovKonstantinovna1306

program raf105;

var a:array[1..3] of integer;

abc,i:integer;

begin

write('Введите число меньше тысячи: ');

readln(abc);

a[1]:=1000;

a[2]:=1000;

a[3]:=1000;

while abc<>0 do

begin

 i:= i+1;

 a[i]:= abc mod 10;

 abc:= (abc-a[i]) div 10;

end;

if (a[1]<>a[2]) and (a[1]<>a[3]) and (a[1]<>1000)

 then abc:= abc+1;

if (a[2]<>a[1]) and (a[2]<>a[3]) and (a[2]<>1000)

 then abc:= abc+1;

if (a[3]<>a[1]) and (a[3]<>a[2]) and (a[3]<>1000)

 then abc:= abc+1;

if abc=3 then abc:= abc-1;

writeln('Количество разных цифр: ',abc+1);

end.

Программа написана на языке PascalABC.NET

baulinanatalia7201

var

A : array [1..999, 1..999] of Integer;

p, s, i, j, m, n: Integer;

begin

// Инициализация переменных для суммы и произведения

s:= 0;

p:= 1;

Write('Введите количество строк - ');

ReadLn(m);

Write('Введите количество столбцов - ');

ReadLn(n);

// Заполнение

for i:=1 to m do

for j:=1 to n do

A[i,j]:=Random(6)+5;

// Вывод массива

for i:=1 to m do

begin

for j:=1 to n do

Write(A[i,j]:3);

WriteLn();

end;

// Подсчёт произведения и суммы

for i:= 1 to m do

begin

j:= i;

s+= A[m-i+1,j];

p*= A[i,j];

end;

WriteLn('Произведение = ', p);

WriteLn('Сумма = ', s);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)дан массив, состоящий из целых чисел. найдите минимальный элемент и индекс. 2)дан массив, состоящий из целых чисел. найдите максимальный элемент в массиве.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dushko
Антонович937
Ольга
turoverova5
lele52
Volochaev
vkorz594
teashop
Инна_Nina1182
Ruzalina_Svetlana1435
lighturist
superbalsa
nanasergevn
iuv61
litlenet