?>
Составить программу на языке паскаль, нахождение периметра и площади по трем сторонам( информатик сказал что нужно чтобы можно было выбирать или площадь или периметр) составить программу на языке паскаль по нахождение элементов одномерного массива заданное от 0 до 100 100
Ответы
a,b,c,p,s:real;
m:integer;
begin
repeat
writeln('a,b,c &');
readln(a,b,c); {Вводим стороны до тех пор пока не выполнится условие сущ треуг}
until (a<b+c)and(b<a+c)and(c<a+b);
writeln('площадь - введите 1 или периметр -2 ?');
{выбираем что считать, если площадь, то вводим 1, периметр - 2}
readln(m);
case m of
1:
begin
p:=(a+b+c)/2;
writeln('S = ',sqrt(p*(p-a)*(p-b)*(p-c))); {вывод площади}
end;
2:writeln(a+b+c); {вывод периметра}
end;
end.
программа 2 Нахождение суммы элементов одномерного массива
const
n=10;
Var
a:array[1..n]of integer;
i,s:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100); {заполнение массива случайными числами [0.100)}
write(a[i]:4); {выводим на экран массив}
s:=s+a[i]; {считаем сумму}
end;
writeln;
writeln('S= ',s); {выводим сумму}
end.