metelkin7338
?>

Уберите лишние скобки у данного логического выражения: y eqv and y) or y)xor (x imp (x xor а затем напишите программу, которая по введённым значениям x и y типа bool, вычисляла бы истинно или ложно данное логическое выражение. vbs

Информатика

Ответы

inainainainaina0073
Dim x
Dim y
x = CBool(InputBox("x="))
y = CBool(InputBox("y="))
Msgbox y Eqv (x And y Or y Xor (x Imp x Xor y))
stusha78938
В качестве примера равномерного кода можно назвать ASCII-таблицу, где каждому из 256 символов сопоставлено двоичное значение от 00000000 до 11111111. Независимо от вероятности появления символа на его представление отводится 1 байт, или 8 бит. Как известно, национальные языки обладают большой избыточностью, то есть разницей между энтропией источника и максимально возможной энтропией, обусловленной равной вероятностью появления любого символа из алфавита. Например, избыточность русского языка составляет 70%, а английского – 50%. Это в частности означает, что некоторые буквы появляются в тексте гораздо чаще других и поэтому использовать равномерное кодирование нерационально.
При неравномерном кодировании часто встречающимся символам сопоставляются более короткие кодовые последовательности, редко встречающимся – более длинные. За счет этого удается значительно сократить объем файла без потерь информации. Существует несколько методов неравномерного кодирования, важнейших из которых является метод Шеннона-Фано.
как-то так 
Shamsulo
1. "Традиционный" вариант
//PascalABC.Net 3.0, сборка 1052
function NOD(a, b: longint): longint;
begin
  while a <> b do if a > b then a := a - b else b := b - a;
  NOD := a
end;

var
  f: Text;
  tNOD: longint;

begin
  Assign(f, 'input.txt'); Reset(f);
  if not Eof(f) then Readln(f, tNOD);
  var n: longint := 1;
  while (not Eof(f)) and (n > 0) and (tNOD > 1) do
  begin
    Readln(f, n);
    if n <> 0 then tNOD := NOD(tNOD, n)
  end;
  Close(f);
  Assign(f, 'output.txt'); Rewrite(f);
  Writeln(f,tNOD);
  Close(f)
end.

2. "Современный" вариант
//PascalABC.Net 3.0, сборка 1052
function NOD(a, b: integer): integer;
begin
  while a <> b do if a > b then a -= b else b -= a;
  Result := a
end;

var
  tNOD: integer := 0;
  n: integer;

begin
  foreach var sn in Readlines('input.txt') do
  begin
    n := StrToInt(sn);
    if tNOD = 0 then tNOD := n
    else
    if n = 0 then break else tNOD := NOD(tNOD, n);
  end;
  WriteAllText('output.txt', IntToSTR(tNOD));
end.

Пример файла input.txt находится во вложении, контрольный результат 4096

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Уберите лишние скобки у данного логического выражения: y eqv and y) or y)xor (x imp (x xor а затем напишите программу, которая по введённым значениям x и y типа bool, вычисляла бы истинно или ложно данное логическое выражение. vbs
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dima-a
Смирнов_Андрей691
Антонович937
litlenet
marusyamr
Vasilevna_Utenkova651
Равилевич_Олеговна1496
zuelv
aleksandramir90
narkimry134
ВасилийМалюга152
Кирилл-Анна1023
Eduardovich_Sergei1062
Popova-Erikhovich
ikalabuhova