Eduardovich_Sergei1062
?>

Дано число n. создайте массив a[2*n+1][2*n+1] и заполните его по спирали, начиная с числа 0 в центральной клетке a[n+1][n+1]. спираль выходит вверх, далее закручивается против часовой стрелки. входные данные программа получает на вход одно число n. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 2 выходные данные 12 11 10 9 24 13 2 1 8 23 14 3 0 7 22 15 4 5 6 21 16 17 18 19 20

Информатика

Ответы

modellisimo-a
Задачка, более менее сложная, но решить можно
klimenko05

Pascal:

1.

var a,b:Integer;

   x:Double;

begin

 writeln('Введите a, b: ');

 readln(a,b);

 x:=a+b;

 writeln(a,'+',b,'=',x);

 x:=a*b;

 writeln(a,'*',b,'=',x);

end.

2.

var a,b:Integer;

begin

 writeln('Введите оценки за две КР: ');

 readln(a,b);

if (a+b)>= 8 then writeln('Молодец!')

else writeln('Подтянись!')

end.

Python:

1.

a, b = int(input('Введите a')), int(input('Введите b'))

x = a+b

print(str(a) + '+' + str(b) + '=' + str(x))

x = a*b

print(str(a) + '*' + str(b) + '=' + str(x))

2.

a, b = int(input('Введите первую оценку')), int(input('Введите вторую оценку'))

if a+b >= 8:

print('молодец!')

else:

print('подтянись!')

Alexander2035

Pascal:

1.

var a,b:Integer;

   x:Double;

begin

 writeln('Введите a, b: ');

 readln(a,b);

 x:=a+b;

 writeln(a,'+',b,'=',x);

 x:=a*b;

 writeln(a,'*',b,'=',x);

end.

2.

var a,b:Integer;

begin

 writeln('Введите оценки за две КР: ');

 readln(a,b);

if (a+b)>= 8 then writeln('Молодец!')

else writeln('Подтянись!')

end.

Python:

1.

a, b = int(input('Введите a')), int(input('Введите b'))

x = a+b

print(str(a) + '+' + str(b) + '=' + str(x))

x = a*b

print(str(a) + '*' + str(b) + '=' + str(x))

2.

a, b = int(input('Введите первую оценку')), int(input('Введите вторую оценку'))

if a+b >= 8:

print('молодец!')

else:

print('подтянись!')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано число n. создайте массив a[2*n+1][2*n+1] и заполните его по спирали, начиная с числа 0 в центральной клетке a[n+1][n+1]. спираль выходит вверх, далее закручивается против часовой стрелки. входные данные программа получает на вход одно число n. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 2 выходные данные 12 11 10 9 24 13 2 1 8 23 14 3 0 7 22 15 4 5 6 21 16 17 18 19 20
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Fomin Korablev1781
dima0218687
davidovalbert6
randat887040
svetlana-ladyga
Irina Svetlana
Шитенков
prik-galina7390
ilma20168
dima-a
Yevsyukov1697
tvmigunova551
AkimovaI1608
vladimir72tatarkov1317
pimenovamar