rusplatok
?>

Написать программу на языке pascal: вычислить 8 целых чисел начиная с 1 не кратных 2 и 5.

Информатика

Ответы

dmitrievanata83538
Var i,n:integer;
begin
n:=1;
i:=1;
write ('Числа не кратные 2 и 5: ');
while i<=8 do
begin
if (n mod 2 <> 0) and (n mod 5 <> 0) then
begin
write (n,' ');
i:=i+1;
end;
n:=n+1;
end;
end.

Написать программу на языке pascal: вычислить 8 целых чисел начиная с 1 не кратных 2 и 5.
Карапетян
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)
alenkadon6
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке pascal: вычислить 8 целых чисел начиная с 1 не кратных 2 и 5.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zimin0082
seletan1
sredova71121
in-1973
Александрович
rb-zakaz
Анатольевич
Константин Андрей
ПетровичЖивотовская1245
hacker-xx1
AkulovaAnastasiya
kush-2640
dmitrovlug8248
kirycha-2000719
Mikhailovna_Litvinova276