Рудаков Бахтовар
?>

Паскаль. составьте программу подсчета числа различных составных элементов массива а(т, т

Информатика

Ответы

brand
Vara: array [1..10] of integer;
b:string;
c,i:integer;
begin
Randomize;
for  i:=1 to 10 do begin
a[i]:=Random(5);
write(a[i]);
end;
b:='';
c:=0;
for  i:=1 to 10 do
if (pos(inttostr(a[i]),b) =0) then begin b:=b+inttostr(a[i]); inc(c); end;
writeln(c);
end.
//ABC Pascal
mmi15
Во-первых, ЯП является инструментом программиста для создания программ. Для создания хороших программ нужны хорошие ЯП. Поэтому одной из движущих сил эволюции ЯП является стремление разработчиков к созданию более совершенных программ.

Во-вторых, процесс разработки программы можно сравнивать с промышленным производством, в котором определяющими факторами являются производительность труда коллектива программистов, себестоимость и качество программной продукции. Создаются различные технологии разработки программ (структурное, модульное, объектно-ориентированное программирование и другие), которые должны поддерживаться ЯП. Поэтому второй движущей силой эволюции ЯП является стремление к повышению эффективности процесса производства программной продукции.

В-третьих, программы можно рассматривать как аналог радиоэлектронных устройств обработки информации, в которых вместо радиодеталей и микросхем используют конструкции ЯП (элементная база программы). Как и электронные устройства, программы могут быть простейшими (уровня детекторного приемника) и очень сложными (уровня автоматической космической станции), при этом уровень инструмента должен соответствовать сложности изделия. Кроме того, человеку удобнее описывать моделируемый объект в терминах предметной области, а не языком цифр. Поэтому третьей движущей силой, ведущей к созданию новых, специализированных, ориентированных на проблемную область и более мощных ЯП, является увеличение разнообразия и повышение сложности задач, решаемых с ЭВМ.

В-четвертых, совершенствование самих ЭВМ приводит к необходимости создания языков, максимально реализующих новые возможности ЭВМ.

В-пятых, программы являются интеллектуальным продуктом, который нужно накапливать и приумножать. Но программы, как и технические изделия, обладают свойством морального старения, одной из причин которого является их зависимость от типа ЭВМ и операционной среды. С моральным старением программ борются путем их модернизации и выпуска новых версий, однако при высокой динамике смены типов ЭВМ и операционных сред разработчики будут только тем и заниматься, что модернизировать старые программы. Поэтому, ЯП должен обеспечивать продолжительный жизненный цикл программы, и стремление к этому является пятой движущей силой развития ЯП.
Какие этапы развития языков программирования можно выделить на сегодняшний день? с чем связана эволю
yuda12

задача 1

поскольку и объем лазерного диска и объем дискеты выражены в одних единицах, можно сразу приступать к вычислениям

разделим объем лазерного диска на объем дискеты

650/1,39=467,6 (приблизительно 468) дискет

задача2а

переведем килобайты в байты, умножив на 1024

5Кб=5*1024=5120 байт переведем байты в биты, умножив на 8

5120 байт*8=40960 бит

задача2б

чтобы перевести биты в байты разделим их на 8

12288бит/8=1536 байт

чтобы перевести байты в килобайты разделим полученное число на 1024

1536/1024=1,5 Кб

задача2в

переведем биты в байты

2^13/2^3=2^10 при делении показатели степеней вычитаются

переведем байты в килобайты

2^10/2^10=1Кб


Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. составьте программу подсчета числа различных составных элементов массива а(т, т
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sadinuraliev263
Matveevanastya0170
vtarasyuk
Yurkov
reinish23
Korneeva1856
kirik197308
Кирилл-Морозова
mnkrasnova
vgolentsova
Андрей
bksenia9775
Avdimov5
Ivan1568
mos-5nica