Prokopeva1062
?>

Написать программу , которая позволяет найти нужные сведения в телефонном справочнике d\phone.txt программа должна запрашивать фамилию человека и выводить его в телефон. если в справочнике есть одинаковые фамилии, то программа должна ввести список всех людей, имеющих эти фамилии.

Информатика

Ответы

delta88
PascalABC.Net

const
//Формат файла
 //Фамилия имя номер    
fl = 'D:\phone.txt';  
var   
t : text;   
c : char;   
Fnm,s : string; 

begin 
assign (t,fl); 
reset (t);   

writeln ('Укажите фамилию'); 
readln (Fnm);  writeln();     

While not eof (t) do   
begin     
s := '';          

//Считываем фамилию
read (t,c);         
While c <> ' ' do       
begin       
s := s + c;       
read (t,c);       
end;

//Если Фамилию нужная то дочитываем            
//иначе переходим к следующему
if s = fnm then     
begin       
write (s+' ');       

While not eoln(t) do         
begin         
read (t,c);         
write (c);         
end;       
readln (t);       
writeln ();     
end 
   
else     
readln (t);        
end; 

close (t); 
end.
borvalmok432

Государственные органы выполняют распорядительные функции по отношению к подчиненным и исполнительные — по отношению к вышестоящим организациям и лицам. В широком смысле слова распорядительно-исполнительные отношения и функции организаций составляют понятие «администрация».

В узком смысле слова под администрацией подразумевается группа официальных лиц (орган), осуществляющая руководство учреждением, организацией, предприятием.

Руководящие работники документируют исполнение своих полномочий, т. е. оформляют свои действия соответствующими документами.

Документирование управленческой деятельности заключается в записи по установленным формам необходимой для управления информации, т.е. в создании документов. Основанием для создания документов является необходимость удостоверения наличия и содержания управленческих действий, передачи информации, хранения и использования ее в течение определенного времени.

Оформленные и удостоверенные в установленном порядке документы являются официальными документами. Одним из важнейших вопросов, решаемых при оформлении официальных документов, является придание документам юридической силы.

Юридическая сила документа — это свойство официального документа, сообщаемое ему действующим законодательством, компетенцией издавшего его органа и установленным порядком оформления.

Важно помнить, что при оформлении каждого документа следует придерживаться рекомендаций ГОСТ Р 6.30—2003 к наличию, размерам площадей, размещению и правильному оформлению всех необходимых для конкретного вида документа реквизитов.

Объяснение: На думаю

Akopovich802

Проектирование

прототип

прототипФоновая часть

прототипФоновая частьМакет

прототипФоновая , дизайн и их демонстрация

прототипФоновая , дизайн и их демонстрацияВыбор стиля интерфейса

прототипФоновая , дизайн и их демонстрацияВыбор стиля интерфейсаДиаграмма переходов

прототипФоновая , дизайн и их демонстрацияВыбор стиля интерфейсаДиаграмма переходовБрейнсторминг и эскизы

прототипФоновая , дизайн и их демонстрацияВыбор стиля интерфейсаДиаграмма переходовБрейнсторминг и эскизыСоздание концепции

Факт:

По последним исследованиям человек может без стресса воспринимать только 3-5 объектов сразу.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу , которая позволяет найти нужные сведения в телефонном справочнике d\phone.txt программа должна запрашивать фамилию человека и выводить его в телефон. если в справочнике есть одинаковые фамилии, то программа должна ввести список всех людей, имеющих эти фамилии.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ИгоревичАндрей
Бурмистрова-Ирина660
testovvanya
buleckovd8724
krisrespect
dimalihachew
nastyakrokhina87
galiyamart6671
kukoleva
Иван1764
Nikolai710
Grigorevna23
rosik76
Olga1509
md-masya