gbfedak220
?>

Исправить ошибки Условие задачи: составить программу обмена местами двух чисел c и d (Числа не дробные Var c, d m:integer; Procedure obmen (а, b:string) var m:integer; begin m:=a; a:=b; b:=m writeln (a, b); begin writeln (‘Введите 3 числа:’); readln (c, d); begin obmen (с;d); writeln (с, ‘ ’, d) end.

Информатика

Ответы

galinaobraz

# Пусть белый цвет это false и соответственно черный true

эта функция определяет цвет по ее координатам, которые не больше числа 8

def checkColor(x, y):

   assert x <= 8 and y <= 8

   color = None

   if x % 2 == 0:

       if y % 2 == 0:

           color = True

       else:

           color = False

   else:

       if y % 2 == 0:

           color = False

       else:

           color = True

   return color

# Задаем координаты первой и второй позиции

k, l, m, n = map(int, input().split())

if checkColor(k, l) == checkColor(m, n):

   print('YES')

else:

   print('NO')

Объяснение:

lescha-77766

# Пусть белый цвет это false и соответственно черный true

эта функция определяет цвет по ее координатам, которые не больше числа 8

def checkColor(x, y):

   assert x <= 8 and y <= 8

   color = None

   if x % 2 == 0:

       if y % 2 == 0:

           color = True

       else:

           color = False

   else:

       if y % 2 == 0:

           color = False

       else:

           color = True

   return color

# Задаем координаты первой и второй позиции

k, l, m, n = map(int, input().split())

if checkColor(k, l) == checkColor(m, n):

   print('YES')

else:

   print('NO')

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исправить ошибки Условие задачи: составить программу обмена местами двух чисел c и d (Числа не дробные Var c, d m:integer; Procedure obmen (а, b:string) var m:integer; begin m:=a; a:=b; b:=m writeln (a, b); begin writeln (‘Введите 3 числа:’); readln (c, d); begin obmen (с;d); writeln (с, ‘ ’, d) end.
Ваше имя (никнейм)*
Email*
Комментарий*