srgymakarov
?>

Даны натуральное число n, целые числа a1, a2, . найти количество и суммы тех членов данной последовательности, которые делятся на 5 и не делятся на написать программу в паскале

Информатика

Ответы

katrinasvr
Const
  nn=100; { максимальное значение n }
var
  i,n,k,s:integer;
  a:array[1..nn] of integer;
begin
  Write('Укажите натуральное число n: '); Read(n);
  Randomize;
  k:=0; s:=0;
  Writeln('Сформированная последовательность');
  for i:=1 to n do begin
    a[i]:=Random(99)+1; { случайное число на интервале [1;99] }
    Write(a[i]:3);
    if (a[i] mod 5=0) and (a[i] mod 7 <>0) then
      begin Inc(k); s:=s+a[i] end;
  end;
  Writeln;
  Writeln('Количество чисел, кратных пяти: ',k);
  Writeln('их сумма равна ',s)
end.

Тестовое решение:
Укажите натуральное число n: 39
Сформированная последовательность
 15 83 69 64 56 50 13 70 55 40 22 82 45 67 31 36 16 52 67 44 63 23 52 62 89 33 40 32 17 14 98 15  5 58 46 68 57 72 90
Количество чисел, кратных пяти: 9
их сумма равна 355
bb495
Решение задачи в прикрепленном текстовом файле.
Описание алгоритма:
Полученные строки хранятся в массиве s.
Элементы массива сортируются так называемой "пузырьковой" сортировкой. Для сравнения двух строк используется функция less, возвращающая истину если первая из двух переданных в функцию строк лексикографически меньше.
А дальше дело за малым: просто выводим элементы отсортированного массива без первых трех символов (номера строк).
Единственная проблема, которая может возникнуть: на некоторых компьютерах программа не работает с русским языком. Но это уже технические проблемы. Само же решение верно.
Удачи!
Anastasiamoscow80
Салат оливье. ингредиенты 1 баночка зеленого горошка (400г) 300 г мяса 4 яйца 350 г картофеля 100 г соленых или маринованных огурцов 150 г лука соль майонез алгоритм приготовления: 1.мясо отварить до готовности (варить около 40 минут после закипания) . 2.остудить. 3.лук мелко покрошить. 4.залить его кипятком и оставить на 10 минут, затем воду слить, лук промыть в холодной воде. 5.мясо нарезать кубиками. 6.картофель почистить, нарезать кубиками. 7. яйца мелко покрошить. 8.огурцы мелко нарезать. 9.смешать картофель, мясо, лук, горошек (воду слить) , яйца, огурцы. 10.посолить. 11. заправить майонезом. 12. украсить по вкусу, например зеленым горошком

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны натуральное число n, целые числа a1, a2, . найти количество и суммы тех членов данной последовательности, которые делятся на 5 и не делятся на написать программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

is0019
ams-sim
av4738046
Некрасова-И
olechka197835
kizyaev6651
centrprof20
ainud
marusyamr
nairahay
topsalon
Dmitrievna-Dmitrii980
Макаров1887
filippovev1
jamaltreid
▲