osechkinandrejj
?>

Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х

Информатика

Ответы

ЕвгенияСергеевна
y=\begin {cases} \displaystyle 3\sin(x)+8, \quad x\ \textless \ \frac{\pi}{2} \\ \displaystyle 4\cos(2x), \quad x\geqslant \frac{\pi}{2} \end {cases}

uses Crt;
const
  Pi=3.14159265;
var
  x,y:real;
begin
  ClrScr;
  x:=0;
  while x<=Pi do begin
    if x<Pi/2 then y:=3*sin(x)+8
    else y:=4*cos(2*x);
    Writeln('x=',x:8:5,',  y=',y:8:5);
    x:=x+Pi/10
  end;
  ReadKey
end.

Тестовое решение:
x= 0.00000,  y= 8.00000
x= 0.31416,  y= 8.92705
x= 0.62832,  y= 9.76336
x= 0.94248,  y=10.42705
x= 1.25664,  y=10.85317
x= 1.57080,  y=-4.00000
x= 1.88496,  y=-3.23607
x= 2.19911,  y=-1.23607
x= 2.51327,  y= 1.23607
x= 2.82743,  y= 3.23607
x= 3.14159,  y= 4.00000
Alena824
Будем выполнять деление числа на основание той системы, в которую будем переводить. Причем, деление с остатком делаем. А частное опять также делим и т.д пока в частном ноль не получим:
37=2*18+1
18=2*9+0
9=2*4+1
4=2*2+0
2=2*1+0
1=2*0+1
А теперь остатки снизу вверх переписываем, это и будет число в требуемой системе
37(10) = 100101(2)
Проверка. В числе 100101 нумеруем разряды, начиная с 0, но идем справа налево:
      число:100101
    разряд: 543210
Номер разряда означает показатель основания. Составляем выражение:
1* 2^{5} +0*2^{4}+0*2^{3}+1*2^{2}+0*2^{1}+1*2^{0}=32+4+1=37
ответ сошелся.
-----------------------------
Действуем аналогично:
94=2*47+0
47=2*23+1
23=2*11+1
11=2*5+1
5=2*2+1
2=2*1+0
1=2*0+1
94_{10} =1011110_{2}
Проверка:
      1011110
      6543210
101110_{10} =1* 2^{6} +0*2^{5}+1*2^{4}+1*2^{3}+1*2^{2}+1*2^{1}+0*2^{0}= \\ =64+16+8+4+2=94
Сошлось
----------------------------------------
64=8*8+0
8=8*1+0
1=8*0+1
64_{10} =100_{8}
Проверка:
       100
       210
1* 8^{2} +0*8^{1}+0*8^{0}=64
Сошлось
Хасанбиевич Колесников716
1. Как я понял, нужно перевести 297(10) в ...(2),...(8) и ...(16).
Тогда:
- 10-ная : 297;
- 2-ная : 100101001;
- 8-ная : 451;
- 16-ная : 129.

2.Как я понял нужно показать как перевести 100101001(2-ная) в 8-ная через триады.
Тогда :
100 101 001
1) 100 = 2^2 = 4;
2) 101 = 2^2 + 2^0 = 4 + 1 = 5;
3) 001 = 2^0 = 1;
Тогда 100101001 (2-ная) = 451(8-ная).

3. 16 = 2^4 = 10000(2-ная);
32 = 2^5 = 100000(2-ная);
64 = 2^6 = 1000000(2-ная);
128 = 2^7 = 10000000(2-ная).
Выведем правило : Если мы переводим в двоичную СС числа, являющиеся степенями двойки, то мы ставим везде ноли, но единицу ставим в том разряде двоичного числа, в который мы возвели двойку, чтобы получить 8;16 и т.п(32 - это 5-ая степень двойки, следовательно мы ставим единицу на 5-ый разряд, а в другие разряды ставим нули : 100000(1 на 5 разряде).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Васильевич Валерьевна
arbekova
zadvornovakrmst
oliayur4encko
Михайлович_гергиевич315
ПаршинАндрей1928
aedunova3
Tatarnikova1507
pbttehnology
alekseydovganich6
nickcook424
sve707ta
Khlustikova_Borisovna
skvorec3424
agaltsova86
▲