taa19707470
?>

Составить таблицу умножения на 7. p.s. написать программу в паскале через while

Информатика

Ответы

mamaevmvv3
// Pascal ABC.NET
var
    i : integer;

begin
    while i <> 11 do begin
        writeln(7*i);
        inc(i);
    end;
end.
Valerii276

ответ:include <iostream>

#include <stdio.h>

#include <cstring>

using namespace std;

int main (){

int length,i,j,kol=0;

char vowel []="AEIOUY";

char text [100];

gets (text); //функция считывает все введённые символы с пробелами до тех пор, пока не будет нажата клавиша Enter

length=strlen (text);

for (j=0; j<=5; j++){

for (i=0; i<=length; i++)

if (text[i]==vowel[j])//сравниваем введённые элементы с заданными значениями строки

kol=kol+1cout << kol << endl return 0;

Объяснение:

Эти значение строки.

A E I O и Y остальные считаются согласными

maksmi

Відповідь:

Нужно закодировать ещё четыре буквы (В, Д, Е, Н), а в дереве есть три свободных узла. Каждое продолжение дерева из свободного узла создаёт два узла вместо одного, то есть количество узлов увеличивается на 1 . Значит, нужно продолжить дерево в одном месте. С точки зрения длины кодов это можно сделать двумя

из узла 10 (длина кода 2 ) получить два узла с длиной кода 3 ;

из узла 001 или 111  (длина кода 3 ) получить два узла с длиной кода 4 .

В первом случае мы получим новые коды длиной 3,3,3,3,  во втором – 2,3,4,4.

Подсчитаем количество знаков для кодирования слова ВВЕДЕНИЕ в каждом их этих случаев. В первом случае длина всех добавленных кодов (буквы В, Д, Е, Н) одинакова –3  бита. Длина кода буквы И задана – тоже 3  бита. Всего получается 8х3=24 бита.

Во втором случае длина добавленных кодов разная. Очевидно, что для получения наименьшей длины самым коротким должен быть код буквы Е (она встречается чаще всех), следующим – код буквы В. Тогда длина кода для Е – 2 бита, для В –3 , для Д и Н – по4 . Всего потребуется  бита. 3х2+2х3+4+4+3=23 бита

Пояснення:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить таблицу умножения на 7. p.s. написать программу в паскале через while
Ваше имя (никнейм)*
Email*
Комментарий*
▲