Ушакова1902
?>

Известно время вылета самолета: hh часов и мм минут, а также продолжительность полета (нм часов и мр минутнапишите программу, которая определяет время прибытия самолета в аэропорт назначение ввиде "чч: мм"

Информатика

Ответы

alexst123012225
Var b,a,hh,mm,hp,mp :integer;
begin
readln(hh,mm,hp,mp);
hh:=hh*60;
hp:=hp*60;
a:=hp+hh+mm+mp;
a:=a div 60;
b:=a mod 60;
writeln(a,':',b);
end.
rsksnb

Обычно в качестве подозреваемых в этом деле выступают сбои в работе ПО, неправильные настройки операционной системы, устаревшие драйверы, неисправности USB-портов компьютера, переходников или самих накопителей.

В зависимости от причин в каждом случае проблема проявляет себя по-разному. Бывает, что компьютер вообще никак не реагирует на флешку или жёсткий диск. В иных ситуациях раздаётся звук подключения нового устройства, но значок накопителя так и не появляется в проводнике. А иногда компьютер просто зависает сразу после контакта с USB-девайсом.

Что делать, если компьютер с Windows не видит флешку или внешний жёсткий диск

Для начала разберитесь, с чем именно возникает проблема: с компьютером, переходником (если подключение происходит через кабель) или накопителем. Попробуйте подключить USB-устройство через другие порты. Если не и вы используете кабель, попробуйте заменить его на запасной. В случае неудачи проверьте, открывается ли накопитель на прочих компьютерах.

Delyaginmikhail

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

   int x, faktorial;

   faktorial = 1;

   cout << "vvedite x" << endl;

   cin >> x;

   if(x <= 0)

   {

       cout << "x dolgen bit' > 0" << endl;

       return 0;

   }

   cout << "faktorial " << x " = "; //выводим заготовку для результата, так как x будет меняться  

   do

   {

       faktorial *= x; //faktorial = faktorial * x;

   }

   //если в условие цикла подставить число, то 0 преобразуется к "ложь", а ненулевое значение к "истина"

   while(--x);//уменьшаем x на 1, затем проверяем его на 0

   cout << faktorial << endl;

   return 0;

}

Объяснение:


1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..whi

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известно время вылета самолета: hh часов и мм минут, а также продолжительность полета (нм часов и мр минутнапишите программу, которая определяет время прибытия самолета в аэропорт назначение ввиде "чч: мм"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kettikis
Анна егорович526
samofar
vallihhh
movlam11
Yevgeniya Bessonov
mon84
anadtacia03108988
vera-classic75
mantseva
slspam
Ligaevruslan
Денис_Петровна
Tyukalova
Paikina Natalya30