Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на языке си для вычисления значений следующих выражений: a=5, c=5 a=a+b-2 c=c+1, d=c-a+d a=a*c, c=c-1 a=a/10, c=c/2, b=b-1, d=d*(c+b+a) выражения, записанные в одной строке, записывать одним оператором-выражением. переменные c и d объявить как целые, переменные a и b – как вещественные. значения переменных b и d вводить с клавиатуры. после вычисления каждого выражения выводить на экран значения всех переменных.
#include <stdio.h>
int main(){
float a=5,c=5;
int b,d;
printf("Здравствуйте!Введите 2 числа:\n");
scanf("%d",&b); scanf("%d",&d);
a += b-2;
d += c-a-1;
a = a*c-1;
a = a/10;
c = c/2;
b--;
d = d*(c+b+a);
printf("В итоге получилось:%F,%F,%d,%d",&a,&b,&c,&d);
return 0;
}