?>
Пусть дано некоторое целое число. требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. и если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.
Ответы
var a,b:integer;
begin
write('Введите целое числo');
readln(a);
if a > 0 then begin
b:=a div 2;
end
else
begin b:=a*a;
end;
write ('b',b);
end.