Рожнов
?>

:написать программу вычисляющую сумму четырех чиселpascalabc) решение: program sum; var a, b, c, d, summa: integer; begin readln(a, b, c, d); summa: = a+b+c+d writeln('ответ равен: ', summa); end. на предпоследней строчке(перед end) выдает ошибку - встречено writeln а ожидалось '; ' что не так?

Информатика

Ответы

anton-www1
В строчке перед writeln пропущена ';'
Olifirenko119
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.
annarom1306

ответ:Задание 4

summ, n = 0, int(input())

for _ in range (n):

   summ += int(input())

float(summ)

print(summ / n)

Задание 5

summ, n = 0, int(input())

from random import randint

for _ in range (n):

   summ += randint(0, 100)

float(summ)

print(summ / n)

Задание 2_6

for i in range(100,1000):

   sum = 0

   for s in range(0, 3):

       i = str(i)

       sum = sum + int(i[s]) ** 3

       i = int(i)

   if sum == i:

       print(i)

Задание 2_7

n = int(input())

for i in range(n):

   if i * i % (10 ** len(str(i))) == i :

       print(i)

Объяснение:

В задании 5, в "random.randint(0,100)" необзательно эти числа, спроси у учителя какой должен быть интервал(тут от 0 до 100) и впиши нужные числа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

:написать программу вычисляющую сумму четырех чиселpascalabc) решение: program sum; var a, b, c, d, summa: integer; begin readln(a, b, c, d); summa: = a+b+c+d writeln('ответ равен: ', summa); end. на предпоследней строчке(перед end) выдает ошибку - встречено writeln а ожидалось '; ' что не так?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fialkaflowers77
mkovanov
russstep
Marianna45
NarekAlekseevich779
fta1309
dvpered
kosbart28
Grigorevna23
kobzev-e
Zashchitin Denis
Краева
moskvichkabakery56
akopsiroyan
nestruev