Галина-Юлия1292
?>

Dev_c++ напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Информатика

Ответы

Ivanova55878
#include <iostream>                
#include <math.h>;               

using namespace std;               
int main(int argc, char* argv[])               
{               
    setlocale(LC_ALL, "Russian");
       double x1,x2,y1,y2,distance;             
 
        cout <<"Введите координату x1:";            
        cin>>x1;                    
        cout <<"Введите координату y1:";            
        cin>>y1;            
        cout <<"Введите координату x2:";            
        cin>>x2;            
        cout <<"Введите координату y2:";            
        cin>>y2;                             
        distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2));      // формула для вычисления расстояния
        cout<<"Расстояние между двумя точками:"<<distance<<endl; 
        system("pause");
}
MikhailovichKrizhnaya578
Во-первых, не whill, а while.
 Во-вторых, цикл с предусловием(while) выполняется только тогда, когда его условие возвращает ложь. Если условие возвращает правду, цикл завершается. Бывает так, что при попытке первой итерации цикла условие уже возвращает правду. В этом случае цикл не будет выполнен ни разу.
 Цикл с предусловием(repeat), наоборот, выполняется, пока условие возвращает правду и завершается ложью. Стоит заметить, что если цикл с предусловием проверяет своё условие перед итерацией, цикл с постусловием делает это после, а это значит, что последний выполнится хотя бы один раз.
office
Основные сочетания клавиш
CTRL+C: копирование
CTRL+X: вырезание
CTRL+V: вставка
CTRL+Z: отмена действия
DELETE: удаление
SHIFT+DELETE: удаление выбранного объекта без возможности восстановления, не помещая объект в корзину
CTRL с перетаскиванием объекта: копирование выделенного объекта
CTRL+SHIFT с перетаскиванием объекта: создание ярлыка для выбранного объекта
Клавиша F2: переименование выбранного объекта
CTRL+СТРЕЛКА ВПРАВО: перемещение точки ввода в начало следующего слова
CTRL+СТРЕЛКА ВЛЕВО: перемещение точки ввода в начало предыдущего слова
CTRL+СТРЕЛКА ВНИЗ: перемещение точки ввода в начало следующего абзаца
CTRL+СТРЕЛКА ВВЕРХ: перемещение точки ввода в начало предыдущего абзаца
CTRL+SHIFT + клавиши со стрелками: выделение блока текста
SHIFT + клавиши со стрелками: выбор нескольких объектов в окне или на рабочем столе, а также выделение текста в документе
CTRL+A: выделение всего документа
Клавиша F3: поиск файла или папки
ALT+ВВОД: просмотр свойств выбранного объекта
ALT+F4: закрытие активного окна или завершение работы активной программы
ALT+ВВОД: просмотр свойств выбранного объекта
ALT+ПРОБЕЛ: вызов контекстного меню активного окна
CTRL+F4: закрытие активного документа в приложениях, в которых одновременно можно открыть несколько документов
ALT+ТАБУЛЯЦИЯ: переход между открытыми объектами
ALT+ESC: просмотр объектов в том порядке, в котором они были открыты
Клавиша F6: поочередный просмотр элементов интерфейса в окне или на рабочем столе
Клавиша F4: отображение панели адресов в папке «Мой компьютер» или в обозревателе Windows Explorer
SHIFT+F10: вызов контекстного меню для выделенного элемента
ALT+ПРОБЕЛ: вызов системного меню для активного окна
CTRL+ESC: вызов меню «Пуск»
ALT+подчеркнутая буква в названии меню: вызов соответствующего меню
Подчеркнутая буква в имени команды открытого меню: выполнение соответствующей команды
Клавиша F10: активация строки меню в используемой программе
СТРЕЛКА ВПРАВО: вызов следующего меню справа или подменю
СТРЕЛКА ВЛЕВО: вызов следующего меню слева или закрытие подменю
Клавиша F5: обновление активного окна
Клавиша BACKSPACE: просмотр содержимого папки, расположенной выше на один уровень в каталоге «Мой компьютер» или обозревателе Windows Explorer
Клавиша ESC: отмена выполняемого задания
SHIFT при загрузке компакт-диска в привод для компакт-дисков: предотвращение автоматического воспроизведения компакт-диска
CTRL+SHIFT+ESC: вызов диспетчера задач

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Dev_c++ напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Николаевич-Золотая832
mkrtchyananaida6995
Voronina747
edvard-b
Платон Демцун
nsn-2012
samuilik-v
Serkova_Elena251
Yurevich1701
I.B.Petrishchev
tanysha1990
IPMelnikovR146
Ольга
Minchenkova
kbndbyb6