zerckaln
?>

Прмогите ! 1) сколько раз выполнится тело цикла for n: =3 to 6 do write (' * '); ? 2) составьте программу, которая 6 раз выведет на экран фразу " я люблю свою родину"! в строку через пробел. 3) составьте блок -схему и напишите программу вывода на экран: а) 5 первых четных натуральных чмсел; б) n первых натуральных чисел.

Информатика

Ответы

petrova-kate3
1) 4
2)
var
I:longint;
begin
for I:=1 to 6 do write('Я люблю свою Родину! ');
end.
3) a)
begin
writeln(2,' ',4,' ',6,' ',8,' ',10);
end;
b)
var
I,n:longint;
begin
readln(N);
for I:=1 to n do werite(I,' ');
end;
kolefe22171
Растровое изображение представляет из себя:
✔ мозаику из очень мелких элементов — пикселей;
сочетание примитивов (это про векторное изображение);
палитру цветов.

Растровое графическое изображение формируется из:
линий
✔ пикселей
графических примитивов (это про векторное изображение)

В векторной графике изображения строятся из:
пикселей (это про растровую графику);
✔ примитивов;
рисунков.

Эффективно представляет изображения фотографического качества:
векторная графика;
✔ растровая графика.

Относительно небольшой объём памяти занимают:
✔ векторные рисунки; (это как правило верно. Но если пытаться делать изображения фотографического качества в векторной графике, файлы будут получаться огромными)
растровые изображения.

Могут быть легко масштабированы без потери качества:
✔ векторные рисунки;
растровые изображения.

Растровое графическое изображение получается:
✔ в процессе сканирования (в остальных случаях - векторная)
при работе с системами компьютерного черчения
при создании рисунка в MS Word

Какой тип графического изображения вы будете использовать при редактировании цифровой фотографии?
✔ растровое изображение
векторное изображение

Что можно отнести к достоинствам растровой графики по сравнению с векторной?
Малый объём графических файлов. (это про векторную)
✔ Фотографическое качество изображения.
Возможность просмотра изображения на экране графического дисплея. (это верно для любой компьютерной графики)
Возможность масштабирования изображения без изменения его качества. (это про векторную)

Файлы, с какой графикой имеют наибольший размер?
✔ Растровой.
Векторной.
Трёхмерной. (обычно простенькая трехмерная графика составляется из примитивов и имеет небольшой размер. Но опять-таки, если ставить целью добиться максимальной естественности изображения, то здесь будет максимальный размер) 

Изображения, какой графики состоят из массива точек (пикселей)?
✔ Растровой.
Векторной
Трёхмерной

Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?
Всего пикселей 64 * 64 = 2^12, на них отводится 512 байт = 2^9 байт = 2^12 бит. Тогда на 1 пиксель отводится всего 1 бит, и в палитре не больше 2^1 = 2 цветов.

В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?
512 = 2^9, 8 = 2^3. В первом случае на 1 пиксель отводится 9 бит, во втором - 3 бита. Размер уменьшился в 3 раза.
Viktorovna_Yurevna
1)
program chik;
var a:array[1..100]of integer;
i,s:integer;
begin
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 5=0)then s:=s+a[i];
end;
write(s);
end.
 2)
program chik2;
var a:array[1..100]of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 2=1)then s:=s+1];
end;
write(s);
end.
3)
program chik3;
var a:array[1..1000]of integer;
i:integer;
begin
for i:=1 to 9 do
begin
read(a[i]);
end;
for i:=1 to 9 do
begin
if(a[i] mod 2=0)then write(a[i],' ');
end;
end. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прмогите ! 1) сколько раз выполнится тело цикла for n: =3 to 6 do write (' * '); ? 2) составьте программу, которая 6 раз выведет на экран фразу " я люблю свою родину"! в строку через пробел. 3) составьте блок -схему и напишите программу вывода на экран: а) 5 первых четных натуральных чмсел; б) n первых натуральных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galinova2911
ksoboleva
annayarikova
tnkul
dksvetlydir
NurlanAleksandrovich
Shevtsov1818
imiryakubov
evageniy79
Olesya-elena1525
kun1969
MArat
Vladimir
infoproletarskay745
vladislavk-market2