maximovpavel9114
?>

Решить ! нужно написать программу! имеется n монет, не различимых на первый взгляд. однако, одна из них фальшивая. фальшивая монета чуть тяжелее, чем настоящая, но во всем остальном полностью идентична настоящим. кроме того, есть чашечные весы без гирь и шкалы (по таким весам, можно определить, какая чаша тяжелее или легче, но нельзя сказать на сколько найти минимальное количество взвешиваний, за которое можно гарантированно определить фальшивку. входные данные входной файл input.txt содержит одно натуральное число n – количество монет (2< =n< =109). выходные данные в выходной файл output.txt выведите минимальное количество взвешиваний.

Информатика

Ответы

ostapbender1111
Pascal:
Var 
 n,a:longint;
beegin
 assign(input,'input.txt');
 reset(input);
 assign(output,'output.txt');
 rewrite(output);
 Readln(n);
 if odd(n) then writeln(N div 2+1) else writeln(n div 2);
end.
Надеюсь правильно . Ж)
 
Викторович

1-ші буын машиналарының элементарлы базасы – электронды вакуумды шамдар

2-ші буын машиналарының элементарлы базасы – транзисторлар

3-ші буын машиналарының элементарлы базасы – кіші интегралды схемалар

4-ші буын машиналарының элементарлы базасы – үлкен интегралды схемалар

5-ші буын машиналарының элементарлы базасы – өте үлкен интегралды схемалар

 1642 жылы француз математигі Блез Паскаль он тоғыз жасында дүние жүзінде бірінші рет қосу машинасы деген атпен белгілі, жетектер мен дөңгелектерден түратын механикалық есептеу машинасын қүрастырды.

1761 жылы ағылшын Д.Робертсон жүгіртпесі бар навигациялық есептеулер жүргізуге арналған логарифм сызғышын жасады. Мүндай қүрал жасау идеясын 1660 жылдары Исаак Ньютон ұсынған болатын.

1833 жылы ол бағдарлама арқылы басқарылатын "Аналитикалық машина" жобасын жасады. Бүл машинада қазіргі компьютерлерде бар барлық негізгі қүраушылар: бастапқы сандар мен аралық нәтижелерді сақтауға арналған жад, жадтан алынған сандармен амалдар орындайтын арифметикалық қүрылғы, берілген бағдарлама бойынша есептеу барысын қадағалап отыратын басқару қүрылғысы, деректерді енгізу мен оларды басып шығару құрылғысы болып табылады.

1945 жылы венгер текті көрнекті американ математигі Джон фон Нейман ұсынған болатын. Нейман бойынша негізгі бөліктер басқару құрылғысы (БҚ) және арифметикалық-логикалық құрылғы (АЛҚ) жады, сырқы жады, енгізу және шығару құрылғылары болып табылады.

rayman777

2-ое задание:

#include <iostream>

int main() {

int number;

std::cout << "Введите число: " << std::endl;

std::cin >> number;

if (number > 0)

 std::cout << "Положительное" <<std::endl;

else if (number < 0)

 std::cout << "Отрицательное" << std::endl;

else

 std::cout << "Ноль" << std::endl;

return 0;

}

1-ое задание:

#include <iostream>

int main() {

double dollars, grivnas;

std::cout << "Введите кол-во долларов: " << std::endl;

std::cin >> dollars;

grivnas = dollars * 28.3;

std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить ! нужно написать программу! имеется n монет, не различимых на первый взгляд. однако, одна из них фальшивая. фальшивая монета чуть тяжелее, чем настоящая, но во всем остальном полностью идентична настоящим. кроме того, есть чашечные весы без гирь и шкалы (по таким весам, можно определить, какая чаша тяжелее или легче, но нельзя сказать на сколько найти минимальное количество взвешиваний, за которое можно гарантированно определить фальшивку. входные данные входной файл input.txt содержит одно натуральное число n – количество монет (2< =n< =109). выходные данные в выходной файл output.txt выведите минимальное количество взвешиваний.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stroeva19651938
gri-7410
гайсанов
danaya3005
Sashagleb19
N-odes-art-school410
moonligh3560
Dmitrievich-Telishev
gardenstreet5
asyaurkova
aleksagrbec39
elav20134518
superkiosk249
kap393
antongenfon