Alekseevich_Elena
?>

Программа паскаль абс определить, является ли число с средним арифметическим чисел а и б (а, б, с-вводятся с клавиатуры (написать программу).

Информатика

Ответы

Marina281
Var a,b,c:real;
begin
readln(a);
readln(b);
readln(c);
if c=(a+b)/2 then writeln('True') else writeln('False');
end.
martinson

10

Объяснение:

Смотри вложение. Клетки: [B], [S] робот пройдёт более 2-х раз -> эти клетки не подойдут под условие. Почему? Потому что каждый цикл робот смещается на 3 клетки влево – через [B], в каждом цикле, робот уже проходит 2 раза, а в следующем цикле он делает это ещё раз, тем самым проваливая условие для данной клетки; [S] – аналогично, поскольку робот, в каждом цикле, пересечёт данную клетку, выходя из клетки [F] в клетку [G].

Для простоты, приведу список клеток из 2 цикла:

[G] станет [S];

[A] станет [B];

[C] станет [D];

[B] станет [E];

[S] станет [F].

Во втором цикле [G] левее на 3 клетки, а её позицию из 1 цикла, теперь, занимает клетка [S].

Нетрудно понять, что ровно 2 раза робот пройдёт только по клетке [C] – [C] станет [D] и больше не будет пройдена роботом.

Остальные клетки робот пройдёт более или менее 2 раз.


Робот движется по клетчатому полю в соответствии с заданной программой. для записи программы использ
afilippov3321

10

Объяснение:

Смотри вложение. Клетки: [B], [S] робот пройдёт более 2-х раз -> эти клетки не подойдут под условие. Почему? Потому что каждый цикл робот смещается на 3 клетки влево – через [B], в каждом цикле, робот уже проходит 2 раза, а в следующем цикле он делает это ещё раз, тем самым проваливая условие для данной клетки; [S] – аналогично, поскольку робот, в каждом цикле, пересечёт данную клетку, выходя из клетки [F] в клетку [G].

Для простоты, приведу список клеток из 2 цикла:

[G] станет [S];

[A] станет [B];

[C] станет [D];

[B] станет [E];

[S] станет [F].

Во втором цикле [G] левее на 3 клетки, а её позицию из 1 цикла, теперь, занимает клетка [S].

Нетрудно понять, что ровно 2 раза робот пройдёт только по клетке [C] – [C] станет [D] и больше не будет пройдена роботом.

Остальные клетки робот пройдёт более или менее 2 раз.


Робот движется по клетчатому полю в соответствии с заданной программой. для записи программы использ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа паскаль абс определить, является ли число с средним арифметическим чисел а и б (а, б, с-вводятся с клавиатуры (написать программу).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Владимир-Денисович1080
fshevxuzheva313
koochma
Gesper63
sergey3699
fotomuha1
iordanekaterina
Ольга
troyasport
missimeri
turovskaya69
Надежда-Алексеевна82
nat5555
lagutkins