Объяснение:
Создание любого документа состоит из основных операций:
· редактирования;
· форматирования.
Набор текста осуществляется с клавиатуры. Но часто документ создается на основе уже имеющегося текста (образца, шаблона, отсканированного фрагмента).
Под редактированием понимается доведение документа до приемлемой кондиции (исправление грамматических и стилистических ошибок, замена и вставка символов, перемещение и удаление фрагментов текста и пр.)
Под форматированием документа обычно понимается преобразование его внешнего вида для улучшения его удобочитаемости и информационной логичности.
Форматирование – это изменение параметров объекта с целью придания объекту некоторой формы.Операции редактирования и форматирования являются столь важными, что инструменты для выполнения этих операций в Office 2007 сосредоточены на вкладке Главная в виде групп предназначенных для выполнения определенных подзадач
· группа Буфер обмена – для работы с фрагментами текста и графическими объектами;
· группа Редактирование для поиска в тексте по образцу и замены.
· группа Шрифт – для настройки параметров текста;
· группа Абзац для настройки параметров абзацев;
· группа Стили для использования готовых стилей оформления текста и создания новых;
Первые две группы в более ранних версиях были представлены в меню Правка, а следующие за ними – в меню Формат.
В группах представлены наиболее часто используемые инструменты. Информацию о полном наборе инструментов группы можно получить в привычном виде, щелкнув на кнопке со стрелкой в нижнем правом углу группы. Например, при щелчке на стрелке группы Абзац открывается привычное по предыдущим версиям окно Абзац
#include <stdio.h>
/* организовать ввод и вывод матрицы в виде отдельных функций. */
void scanMatrix(unsigned n, int matrix[n][n])
{
printf("Enter matrix elements, separated by spaces:\n");
for (unsigned i = 0; i < n; i++)
{
for (unsigned j = 0; j < n; j++)
{
scanf("%d", &matrix[i][j]);
}
}
}
void printMatrix(unsigned n, int matrix[n][n])
{
printf("These are matrix elements:\n");
for (unsigned i = 0; i < n; i++)
{
for (unsigned j = 0; j < n; j++)
{
printf("%d ", matrix[i][j]);
}
printf("\n");
}
}
int main()
{
unsigned n;
/* организовать ввод квадратной матрицы размера nxn из целых чисел; */
printf("Enter matrix dimension: ");
scanf("%u", &n);
int matrix[n][n];
scanMatrix(n, matrix);
/* возвести в квадрат все отрицательные элементы матрицы; */
for (unsigned i = 0; i < n; i++)
{
for (unsigned j = 0; j < n; j++)
{
if (matrix[i][j] < 0)
{
matrix[i][j] *= matrix[i][j];
}
}
}
/* переставить нулевые элементы первой строки матрицы в ее начало; */
unsigned lastReplacableIndex = 0;
for (unsigned i = 1; i < n; i++)
{
if (matrix[0][i] == 0)
{
int temp = matrix[0][lastReplacableIndex];
matrix[0][lastReplacableIndex] = matrix[0][i];
matrix[0][i] = temp;
lastReplacableIndex++;
}
}
printMatrix(n, matrix);
}
Поделитесь своими знаниями, ответьте на вопрос:
Входные данные некоторый программы записаны в текстовый файл. в каждой строке файла содержится два целых и три вещественных числа, разделенные пробелами. напишите программу, которая выводит на экран сумму целых и сумму вещественных чисел из каждой строки.
f:Text;
i,j:integer;
a,b,c:real;
begin
Assign(f,'MyFile.txt');
Reset(f);
while not eof(f) do begin
Read(f,i,j); Readln(f,a,b,c);
Writeln(i+j,' ',a+b+c)
end;
Close(f)
end.