gk230650
?>

Составить программу паскаль. вывести на экран название операции сравнения, соответствующей введенному с клавиатуры символу: > , < , =. ответ записать в виде: "была введена операция сравнения-равно".

Информатика

Ответы

Сурат1199
Var a:char;
begin
write('Введите символы операции сравнения: ');
readln(a);
case a of
  '>' : writeln('Была введена операция сравнения - больше');
  '<' : writeln('Была введена операция сравнения - меньше');
  '=' : writeln('Была введена операция сравнения - равно');
else
  writeln ('Вы ввели непонятные системе символы');
end;
end.
vkaloshin
#include <stdio.h> 
#include <stdlib.h>

int main() 

   int n=10;
   int max = 20, min = 10;
   float a[n];
   float b;
   float sum=0;

   srand (time(NULL)); 
   for (int i=0; i<n; i++) {
        a[i] = (float) rand() / RAND_MAX*(max-min)+min;
        printf ("%.2f ", a[i]);
   }
    printf("\n");
    printf("b = ");
    scanf("%f",&b);
    for (int i = 0; i<n; i++) {
    if (a[i] > b) sum+=a[i];
    }
    printf("sum = %.2f\n", sum);
    return 0;
}

Пример:
11.93 14.67 18.25 13.99 14.33 11.68 15.80 17.83 13.61 18.20
 b = 15
sum = 70.08
vvk2008
#include <iostream>
using namespace std;

string evenOrOdd(int n)
{
if (n % 2 == 0) {
return "чётное";
}
else {
return "нечётное";
}
}

string digitCount(int n)
{
if ( (int) n / 1000 > 0 ) {
if (n > 9999){
return "n-значное";
}
else {
return "четырёхзначное";
}
}
else if ( (int) n % 1000 / 100 > 0 ) {
return "трёхзначное";
}
else if ( (int) n % 100 / 10 > 0 ) {
return "двузначное";
}
else {
return "однозначное";
}
}

int main()
{
int n;
cout << "n = ";
cin >> n;
cout << evenOrOdd(n) << ' '
<< digitCount(n) << ' '
<< "число" << endl;
return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу паскаль. вывести на экран название операции сравнения, соответствующей введенному с клавиатуры символу: > , < , =. ответ записать в виде: "была введена операция сравнения-равно".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

atupicyn754
vrn3314
PopovViktorovna
Informatika 62 dars 3-4 dars 10 sinf
nchalov2
Банова_Елена431
Galkin Vladimirovich729
vanvangog199826
mzia-mzia-60682
uzunanna19922488
Struev730
el-dent12
orange-salon-job77
ddavydov1116
Obukhov-Buriko
Александр Елена1290