slava-m-apt
?>

Написать программу на языке с++ : в одной старинной мудрец предложил шаху в качестве награды за услугу выдать зерно. причем количество зерна оговорил так: на первую клетку шахматной доски положить 1 зерно, на 2-ую - 2, на 3-ю - 4, на 4-ую - 8 и т.д. составить программу, с которой можно вычислить, на какой клетке суммарное количество зерен превысит n штук.

Информатика

Ответы

AleksandraRuslan504
//
//   Разработал GonanSoft
//
int i; 
unsigned long long k=0; // сумма зёрен на i-ом шаге
unsigned long long s=1; // количество зерен в i-ой клетке 
unsigned long long n; // переменная признак окончания

cout << 'количество зерен '; 
cin>>n;
for (i = 1; i <= 64; i++) 
{
  k=k+s;
  if (n<k)
    break;
  s=s<<1; 
}

if (n<>18446744073709551615)  //это проверка на максимум зёрен
  cout << 'Номер клетки = ' << i << '\n';
else
  cout << 'Сумма зёрен не превысит 18446744073709551615  ' << i << '\n';
//
Lopatkin_Shchepak174

вот сделай лучшим ответом

Объяснение:

Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.

Черчение это - когда изображают предметы приёмами черчения, не полагаются на один глазомер и верность руки, а пользуются разными вс инструментами. Зато от чертежа требуется точное воспроизведение размеров предмета, в определённом масштабе, вследствие чего перспективное изображение употребляется весьма редко (так как оно искажает размеры частей) и заменяется проекциями, по правилам начертательной геометрии. С развитием применений графической статики при черчения стали легко и быстро решать множество численных задач, встречающихся при проектировании сооружений и машин и требующих сложных алгебраических выкладок.

Они не связаны потому-что на информатике всё делается на компьютере а на черчении своими руками рисует что-то (что-то не нужно писать)

idalbaev

Задача 1.

#include <stdio.h>

int main() {

   int n;

   scanf("%d", &n);

   printf("Объём=%d\n",n*n*n);

   printf("Площадь=%d",n*n);

   getchar();

}

Задача 2.

#include <stdio.h>

int main() {

   float R1, R2, R3;

   scanf("%f", &R1);

   scanf("%f", &R2);

   scanf("%f", &R3);

   printf("R_общ.=%f",(R1*R2*R3)/(R1*R2+R2*R3+R1*R3));

}

Задача 3.

#include <stdio.h>

#include <math.h>

int main() {

   float h;

   scanf("%f", &h);

   printf("р=%f",sqrtf(2*h/9.81));

   getchar();

}

На решение этих задач я потратил примерно 2 часа. Будьте добры и поставить мне за усилия сердечко и 5 звёзд! ;-)


1. Дана длина ребра куба. Найти объем куба и площадь его боковой поверхности. 2. Три сопротивления R
1. Дана длина ребра куба. Найти объем куба и площадь его боковой поверхности. 2. Три сопротивления R
1. Дана длина ребра куба. Найти объем куба и площадь его боковой поверхности. 2. Три сопротивления R

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++ : в одной старинной мудрец предложил шаху в качестве награды за услугу выдать зерно. причем количество зерна оговорил так: на первую клетку шахматной доски положить 1 зерно, на 2-ую - 2, на 3-ю - 4, на 4-ую - 8 и т.д. составить программу, с которой можно вычислить, на какой клетке суммарное количество зерен превысит n штук.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vsemvsego306
Vyacheslavovich1431
Станиславовна196
ПаршинАндрей1928
козлов
nash-crimea2019
nopel91668
nchorich55
Sakmarov
Овчинников_Грузман
wwladik2606222
dyatchina63
hello
martinzdraste
Михайлович_гергиевич315