m, n, i, j: integer;
s: real;
a: array[,] of real;
write('Введите S: ');
read(s);
write('Введите M, N: ');
read(m, n);
setlength(a, m + 1, n + 1);
writeln('Введите элементы матрицы: ');
for i := 1 to m do
for j := 1 to n do
read(a[i, j]);
for i := 1 to m do
begin
for j := 1 to n do
if a[i, j] <> s then
begin
writeln(a[i, j]);
break;
end;
if a[i, j] = s then
writeln('-');
end;
end.
Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
Объяснение:
нажмите лучших ответ и лайк
Робототе́хника (от робот и техника; англ. robotics — роботика, роботехник) — прикладная наука, занимающаяся разработкой автоматизированных технических систем и являющаяся важнейшей технической основой развития производства
Робототехника опирается на такие дисциплины, как электроника, механика, кибернетика, телемеханика, мехатроника, информатика, а также радиотехника и электротехника. Выделяют строительную, промышленную, бытовую, медицинскую, авиационную и экстремальную (военную, космическую, подводную) робототехнику.
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу которая осуществляет ввод в массив с клавиатуры 10 элементов и отрицательные числа возводят в квадрат, а из неотрицательных извлекают квадратный корень
i:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if a[i]<0 then a[i]:=sqr(a[i])
else a[i]:=sqrt(a[i]);
end;
for i:=1 to 10 do
write(a[i],' ')
end.