LYuBOV
?>

Информатика: задана строка, состоящая из латинских букв, длиной от 7 до 256 символов. на каждом шаге из строки можно удалить одгу или несколько стоящих рядом букв. напишите программу которая находит наименьшее количество шагов за которое можно получить слово alcatel. если это невозможног то вывести 1. входные данные: входной файл inp.txt в одной строке входного файла содержится слово. входные данные: программа должна вывести в выходной файл out.txt одну цифру наименьшее количество шагов, чтобы получить слово alcatel, или 1

Информатика

Ответы

leeteukism
Задана строка состоящая из латинских букв, длиной от 7 до 256
lsyrbu
Static void Main(string[] args)       
{           
     int count = 0;           
     Console.Write("Введите размерность массива: ");           
     int n = Convert.ToInt32(Console.ReadLine());           
     int[] mas = new int[n];           
     Console.WriteLine("Заполните массив: ");           
     for (int i = 0; i < n; i++)           
     {               
          Console.Write("\t{0} элемент массива: ", i + 1);             
          mas[i] = Convert.ToInt32(Console.ReadLine());           
     }           
     for (int i = 0; i < n; i++)               
          if (mas[i] > 0 && mas[i] % 2 == 0)                   
               count++;           
     Console.WriteLine("Из {0} элементов массива {1} элементов являются положительными четными",n,count);           
     Console.WriteLine("{0}%  элементов являются положительными четными", (double)count/n*100);           
     Console.ReadLine();       
}
sttig
Var a,b,c,d,x,y: real;
begin
  write('задайте a b c d через пробел:  ');
  readln(a,b,c,d);
  write('координаты точки x y через пробел: ');
  readln(x,y);
  if a>b then swap(a,b);
  if c>d then swap(c,d);
  if ((y>=a) and (y<=b) and (x>=c) and (x<=d)) then
  writeln('точка принадлежит области')
  else writeln('точка не принадлежит области');
end.
  
задайте a b c d через пробел:  1 2 3 4
координаты точки x y через пробел: 3.5 1.5
точка принадлежит области

задайте a b c d через пробел:  1 2 3 4
координаты точки x y через пробел: 2 2
точка не принадлежит области

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика: задана строка, состоящая из латинских букв, длиной от 7 до 256 символов. на каждом шаге из строки можно удалить одгу или несколько стоящих рядом букв. напишите программу которая находит наименьшее количество шагов за которое можно получить слово alcatel. если это невозможног то вывести 1. входные данные: входной файл inp.txt в одной строке входного файла содержится слово. входные данные: программа должна вывести в выходной файл out.txt одну цифру наименьшее количество шагов, чтобы получить слово alcatel, или 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dimaproh
nikitavertiev98400
mvolkov8
vrn3314
Soliyabronzoni
ivstigres65
VladimirovnaBugrova
Андрей-Викторовна1910
ev27076878
delfa-r6289
armynis8
cleopatra1959
Штакина1568
makitra08
anton