Лебедев972
?>

Составить программу которая выводит на экран все двухзначные числа у которых 1-я цифра в два раза больше второй.

Информатика

Ответы

Nugamanova-Tatyana840
Program zadanie;
var i,j,r:integer;
begin
writeln('Высчитываем числа');
for i:=1 to 9 do
    for j:=1 to 9 do
        if (i=2*j) then
        begin
        r:=i*10+j;
        writeln(r);
        end;
end.
samuilik-v

Основная идея состоит в том, что каждая сумма – это сумма цифр, то есть она не может быть больше 18. Значит, надо разбивать каждое возможно получившееся число на однозначные и двузначные числа и смотреть, может ли такое быть.

1212 – возможно, например, из числа 666 (6+6 = 12, 6+6 = 12, итог: 1212)

129 – возможно, например, из числа 936 (9+3 = 12, 3+6 = 9, итог: 129)

123 – возможно, например, из числа 930

1218 – невозможно. Это число можно разбить только на два двузначных числа, но тогда 12 и 18 записаны в порядке возрастания, а по условию должно быть наоборот

1812 – возможно, например, из числа 993

312 – невозможно. Это число можно разбить либо на 3 и 12, либо на 31 и 2. В первом случае числа расположены в порядке возрастания, а во втором нельзя получить 31, так как сумма цифр не больше 18

912 – невозможно (аналогично с 312)

112 – возможно, например, из 920

Итого 5 чисел могут получиться.

ответ: 5

shakovaea

1)Монитор,(на счет магнитофона не уверен, сам по себе именно магнитофон никак не является устройством ПК, но если подразумевают пол этим словом динамик ПК, то подходит)

2)Получение

3)Электрический ток

4)Анатомический муляж

5)102 бита

6)48

7)из перечисленных ниже нет верного ответа. 568 в десятичной = 1 000 111 000 в двоичной.

8)АВИБА

9)Представленные ответы неправильны, так как не являются двоичным кодом(присутствуют двойки)+не указано к какой системе счисления принадлежит y (если x - очевидно 16-ти ричная, то y может быть как 16 так и 10

10) И снова нет верного ответа из предложенных, т.к. получится D8

11)800 бит

12) (Ячейки excel где?)

13) Аналогично 12

14)тоже

15)27

16)User-name

17)c*.c*

18)145.92.128.0

19)Верного ответа нет. Правильно: 22

20) 5

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая выводит на экран все двухзначные числа у которых 1-я цифра в два раза больше второй.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

travkinadjey31
prettymarina2015
enot1975
Ярослав
beliaevabeliaeva-olesya35
Minchenkova
Александрович Алексеевна
kap393
sargisyan
Агибалов428
katarinacorvus825
Оксана170
Petrushin482
edubenskaya
spodobnyi