Лилин1079
?>

Нужно написать программу на языке паскаль дан массив из 10 целых чисел. определить, что больше: среднее арифметическое максимального и минимального элементов, или среднее арифметическое всех элементов массива.

Информатика

Ответы

Александрович Алексеевна
Var m : array[1..10] of Integer;
max,min,sum,i : Integer;
Begin
  min:=1; max:=1; sum:=0;
  For i:=1 to 10 do
  Begin
   m[i]:=Random(100);
   sum:=sum+m[i];
   If m[i]<m[min] then min:=i;
   If m[i]>m[max] then max:=i;
   Writeln(m[i]);
  end;
  Writeln('Ср.арифм. макс.и мин. элементов: ', (m[max]+m[min])/2);
  Writeln('Ср.арифм. всех элементов: ', sum/10);
end.
fakelel
По горизонтали:1. Гибкий магнитный диск.2. Устройство для вывода информации на бумажный носитель.3. Запоминающее устройство.4. Жесткий диск.5. Устройство ввода информации.6. Устройство ввода информации с бумажного носителя.7. Сверхоперативная память.По вертикали:3. Устройство обработки информации.5. устройство вывода информации.8. Вычислительная система.7. Клавишное устройство ввода информации.9. система проводов. ответы:По горизонтали:1. дискета, 2. принтер, 3. память, 4. винчестер, 5. мышь, 6. сканер, 7. кэш.По вертикали:3. процессор, 5.монитор, 8. компьютер, 7.клавиатура, 9.ю шина.
alazaref
Если, например, Х = 5 сек, то за 5 сек Флэш выпустит 2 молнии, а за 10 сек - 3.
То есть количество молний A = int(Y : X) + 1, где
Y = N*60 + M - количество отведенного времени в секундах.
Вся суть программы:
X = Input (input.txt, X); // Принимаем секунды из файла, пишем в переменную X
N = Input (input.txt, N); // Принимаем минуты из файла, пишем в переменную N
M = Input (input.txt, M); // Принимаем секунды из файла, пишем в переменную M
Y = N*60 + M; // Вычисляем отведенное время в секундах
A = int(Y : X) + 1; // Вычисляем количество молний
Output (A, output.txt); // Выводим его в файл.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на языке паскаль дан массив из 10 целых чисел. определить, что больше: среднее арифметическое максимального и минимального элементов, или среднее арифметическое всех элементов массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

milkiev
atenza3736
Burov1446
maglevanyycpt
maestro6838
katya860531
Александрович Владимирович
sklad
ibswoklol1362
Alex17841
ohussyev
Киларджиева Диана440
zoocenterivanoff51
Stanislavovna1237
levickaalubov5