skalegin68
?>

1. дано целое число а. если значение а > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. написать программу для решения этой . программа должна иметь дружественный интерфейс. протестировать программу для a=3, a=0, a=-12. 2. даны два действительных числа x и y, не равные друг другу. заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. программа должна иметь дружественный интерфейс. программы на паскале

Информатика

Ответы

vallium8354
1.
Var A : Integer;
Begin
  Write('Введите число A: '); Readln(A);
  If A>0 then A:=A+1 else A:=A-1;
  Writeln('Новое значение числа A: ',A);
end.

2.
Var A,B,c : Real;
Begin
  Write('Введите число A и B: '); Readln(A,B);
  c:=(A+B)/2;
  If A<B then
  Begin
   B:=A*B*2;
   A:=c;
  end else
   Begin
     A:=A*B*2;
     B:=c;
   end;
  Writeln('Новые значения A и B: ',A:6:2,B:6:2);
end.
mv7095
Шифр Цезаря, самое тривиальное что приходит в голову. Для несведущих, замена прямого текста согласно таблице шифрования, которая формируется следующим образом: первому символу алфавита соответствует k+1-ый символ этого же алфавита, второму - k+2-ый, третьему - k+3-ый и так далее.
К самому заданию.
Ъуйшябъшцйф ёш здшёэкл Бджжгш аъюаьёжв йбйкэеу Ыишдыши.
В данном шифре алфавит смещён на 25 позиций.
Расшифровка:
Высаживаюсь на планету Илоока звёздной системы Гралгар.
(комментарий автора Космическим Рейнджерам за счастливое детство)
Матфеопуло1006
Средняя глубина Черного моря — 1271 м, наибольшая- 2245 метров (вблизи Синопа). Протяженность моря между западной и восточной точками —около 1167 км, между северной и южной-624 километра. Наименьшая протяженность акватории в меридиональном направлении, между Крымом и берегом Анатолии (азиатской части Турции), 263 км. Длина береговой линии Черного моря — 4090 км, коэффициент изрезанности — около 1,8.На площади, занятой Черным морем, можно разместить две Великобритании. Азовское море соединяется с Чёрным морем Керченским проливом. Площадь его — около 38000 кв. км. Преобладающие глубины — 9-13 м, наибольшая — 14,5 м. Берега изрезаны слабо. Крупнейший залив - Таганрогский; у западного берега - система мелких заливов Сиваш. Южный берег моря холмистый, для северного и северо-восточного берегов характерны косы. В Азовское море впадают реки Дон, Кубань и другие, образуя лиманы. Климат континентальный, средняя температура воздуха летом +23?-24?, зимой -7 ?С. С конца декабря до конца февраля покрывается льдом. Течения неустойчивы. Вода отличается мутностью, море богато рыбой: судак, лещ, кефаль, осётр, и т. д. Главные порты: Ростов-на-Дону, Таганрог, Азов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. дано целое число а. если значение а > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. написать программу для решения этой . программа должна иметь дружественный интерфейс. протестировать программу для a=3, a=0, a=-12. 2. даны два действительных числа x и y, не равные друг другу. заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. программа должна иметь дружественный интерфейс. программы на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Drugov_Vladimirovna
azarovaelena19812
kristal1
osandulyak
ohussyev
tomogradandrey
akrivoz
barekyan096140
Konstantinovna1936
anna241273
Ирина-Макаркина253
ooo-helpvet44
baranovaas
Femida76
annaar497