annaar497
?>

Лена в октябре ежедневно записывала показания температур в дневник наблюдений составьте программу, которая выводит количество дней с температурой меньше 0 градусов. составьте компьютерную программу на языке паскаль.

Информатика

Ответы

snow8646
Два варианта : с массивом и без

с)
var a:array[1..100] or integer;
      n[коммент от автора: кол-во дней],k,i:integer;
begin
readln(n) [коммент от автора: можно вручную записать если не дается];
For i:=1 to n do
  read(a[i]);
k:=0;
For i:=1 to n do
  If a[i]<0 then
  k:=k+1;
writeln(k);
end.

БЕЗ МАССИВА
var n,k,c,i:integer;
begin
readln(n);
k:=0;
For i:=1 to n do
  begin
  c:=0;
readln(c);
If c<0 then
  k:=k+1;
end;
writeln(k);
end.
alena

Это результат использования двух разных стандартов обозначения единиц измерения количества информации (одно и то же обозначение единицы измерения может пониматься по разному).

Производители жёстких дисков пишут их объём в "десятичных" единицах (в них объём диска в цифрах получается больше, потому что сама единица меньше).

Десятичный терабайт:  1 ТБ = 10¹² байт = 1 000 000 000 000 байт

А в операционной системе компьютера обычно этот объём показывается в "двоичных" единицах (и в них значение объёма диска получается меньше, т.к. сама единица больше).

Двоичный терабайт: 1 ТБ = 2⁴⁰ байт = 1 099 511 627 776 байт

Двоичный гигабайт: 1 ГБ = 2³⁰ байт = 1 073 741 824 байт

Значит, ОС покажет объём диска так:

-в терабайтах:  10¹² / 2⁴⁰ ≈ 0,91 ТБ

-в гигабайтах: 10¹² / 2³⁰ ≈ 931,3 ГБ

Также, сколько то гигабайт система может зарезервировать для своих нужд, и доступный пользователю объём будет ещё меньше (как раз около 900 ГБ).

Объяснение:

Двоичные единицы были в компьютерной технике можно сказать с самого начала. И там они "родные", естественные- ведь компьютеры то построены на двоичной логике (почти все).

А отсюда вытекает количество адресуемой памяти- это степень двойки.

Микросхема памяти с четырьмя адресными входами позволяет обратиться к 2⁴ = 16-ти ячейкам памяти.

Шина адреса из 10 линий позволяет адресовать 2¹⁰ = 1024 ячейки.

Отсюда он, двоичный килобайт: 1 КБ = 2¹⁰ = 1024 байта

Близко к тысяче, поэтому стали обозначать по аналогии с приставкой "-кило" (к), но только большой буквой (К), чтобы хоть как то отличать от стандартной приставки СИ.

Уже тут приставки пишутся почти одинаково, но отличаются по значению, ведь стандартная "к" -это тысяча (1 000)

Потом памяти стало больше, и появился мегабайт:

1 МБ = 2²⁰ = 1 048 576 байта

Здесь различие в написании двоичных и десятичных приставок уже пропало полностью, но при этом стандартная приставка "-мега" (М) означает миллион (1 000 000).

Потом гигабайт, терабайт... С каждой следующей отличие от стандартных приставок сильно увеличивалось (для ТБ это уже значительные 10%).

И, был принят стандарт, использующий стандартные (десятичные) приставки (1 кБ = 1 000 Б,  1 МБ = 1 000 000 Б,  итд), а двоичные единицы измерения предлагалось переименовать в КиБ (кибибайт), МиБ (мебибайт), итд.

Но конечно, путаницы стало только ещё больше, причём многократно. Ибо далеко не все хотят переходить на новый стандарт. Причин хоть отбавляй- от странного и длинного названия единиц, до того факта что всё начиная с самых истоков основано на старых единицах и их написании- вся документация, все программы, сама аппаратура даже... Да и людям так привычнее, так удобнее. Мало кто хочет переходить на десятичные единицы, а уж ещё меньше- на переименованные.

Хотя, конечно всё же некоторые переходят, особенно кому это выгодно- те же производители носителей информации- жёстких дисков, DVD-дисков, флешек даже.

И чем больше используют десятичных единиц, тем больше путаницы становится.

P.S. В общем, крепитесь, ребята. Нам в этом компоте всю жизнь придётся вариться. Если что непонятно- смотрите полный размер в байтах (где это доступно, конечно). А недоступно- читайте теорию или справку наконец уж. И да пребудет с вами Сила :)

Светлана
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Лена в октябре ежедневно записывала показания температур в дневник наблюдений составьте программу, которая выводит количество дней с температурой меньше 0 градусов. составьте компьютерную программу на языке паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nikolaevich_Vladimirovich1509
ИвановичБогословский280
metegina4
delonghisochi
Евгений
tatyana58
галина
premiumoft
Египтян2004
Кирилл_Гульницкий
Решите Информатика 8 класс​
hotnuts
Владислав-Аветисян217
Bogataya Vladimir318
Наталья Юрьевич1228
info2