Pascalabc составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечётными значениями.
Var A:array[1..8] of Integer; i,k:integer; begin For i:=1 to 8 do begin A[i]:=Random(1,10); Write(A[i],' '); end; For i:=1 to 8 do If A[i] mod 2=0 then k:=k+1; Wrieln(k); end.
elena-novikova-1992
02.03.2020
Файл --> A --> Б
Если разрешение файла увеличили в три раза, а частоту дискретизации уменьшили в пять раз, значит объем файла был увеличен в три раза и уменьшен в пять.
Время передачи изменяется пропорционально объему файла, то есть, к примеру, увеличив объем в три раза, время передачи будет увеличено также в три раза.
В пункт А файл был передан за 50 секунд. Определим время передачи в пункт А нового (изменённого) файла.
50 * 3 / 5 = 30 секунд.
То есть если бы мы передавали измененный файл в пункт А, то он был бы передан за 30 сек.
Пропускная между А и Б в шесть раз выше, значит из пункта А в пункт Б файл был передан за
30 / 6 = 5 секунд.
kovalenko262
02.03.2020
По территориальной распространенности
•PAN (Personal Area Network) — персональная сеть, предназначенная для взаимодействия различных устройств, принадлежащих одному владельцу. •LAN (Local Area Network) — локальные сети, имеющие замкнутую инфраструктуру до выхода на поставщиков услуг. Термин «LAN» может описывать и маленькую офисную сеть, и сеть уровня большого завода, занимающего несколько сотен гектаров. Зарубежные источники дают даже близкую оценку — около шести миль (10 км) в радиусе. Локальные сети являются сетями закрытого типа, доступ к ним разрешен только ограниченному кругу пользователей, для которых работа в такой сети непосредственно связана с их профессиональной деятельностью. •CAN (Campus Area Network — кампусная сеть) — объединяет локальные сети близко расположенных зданий. •MAN (Metropolitan Area Network) — городские сети между учреждениями в пределах одного или нескольких городов, связывающие много локальных вычислительных сетей. •WAN (Wide Area Network) — глобальная сеть, покрывающая большие географические регионы, включающие в себя как локальные сети, так и прочие телекоммуникационные сети и устройства. Пример WAN — сети с коммутацией пакетов (Frame relay), через которую могут «разговаривать» между собой различные компьютерные сети. Глобальные сети являются открытыми и ориентированы на обслуживание любых пользователей. •Термин «корпоративная сеть» также используется в литературе для обозначения объединения нескольких сетей, каждая из которых может быть построена на различных технических, программных и информационных принципах.
По типу функционального взаимодействия
•Клиент-сервер •Смешанная сеть •Одноранговая сеть •Многоранговые сети
По типу сетевой топологии
•Шина •Кольцо •Двойное кольцо •Звезда •Ячеистая •Решётка •Дерево •Fat Tree
По типу среды передачи
•Проводные (телефонный провод, коаксиальный кабель, витая пара, волоконно-оптический кабель) •Беспроводные (передачей информации по радиоволнам в определенном частотном диапазоне)
По функциональному назначению
•Сети хранения данных •Серверные фермы •Сети управления процессом •Сети SOHO, домовые сети
По скорости передач
•низкоскоростные (до 10 Мбит/с) , •среднескоростные (до 100 Мбит/с) , •высокоскоростные (свыше 100 Мбит/с) ;
По сетевым операционным системам
•На основе Windows •На основе UNIX •На основе NetWare •На основе Cisco
По необходимости поддержания постоянного соединения
•Пакетная сеть, например Фидонет и UUCP •Онлайновая сеть, например Интернет и GSM
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Pascalabc составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечётными значениями.
i,k:integer;
begin
For i:=1 to 8 do
begin
A[i]:=Random(1,10);
Write(A[i],' ');
end;
For i:=1 to 8 do
If A[i] mod 2=0 then
k:=k+1;
Wrieln(k);
end.