Кто -святой. составить программу, которая заполняет 11 элементов одномерного массива случайным образом, вычисляет их сумму, определяет min элемент в массиве
Var x : array[1..11] of integer; n,s,i,min : integer; begin Randomize; n:=11; writeln('Сгенерированный массив:'); for i:=1 to n do begin x[i]:=random(21)-10; write(x[i],' '); end; writeln; s:=0; min:=x[1]; for i:=1 to n do begin if x[i]<min then min:=x[i]; s:=s+x[i] end; writeln('s = ',s:5,' min=',min); end.
fotomuha1
22.08.2021
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016 begin Range(-50,50,5).Tabulate(x->(x+4)*sqr(x+4)-sin(x)).Print(NewLine) end.
#include <iostream> #include <iomanip> int main() { using namespace std; const int N = 4; const int M = 4; int Y[N][M];
//как-нибудь заполняем матрицу for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) Y[i][j] = (i + 1) * (j + 1);
//выведем её на экран for (int i = 0; i < N; ++i) { for (int j = 0; j < M; ++j) cout << setw(3) << Y[i][j]; cout << endl; }
//находим сумму элементов побочной диагонали int S = 0; for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) if (j == M - 1 - i) S = S + Y[i][j]; cout << "Sum of adverse diagonal of array: " << S << endl;
//находим сумму всех элементов матрицы int Sum = 0; for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) Sum = Sum + Y[i][j]; cout << "Sum of all elements of array: " << Sum << endl; return 0; }
n,s,i,min : integer;
begin
Randomize;
n:=11;
writeln('Сгенерированный массив:');
for i:=1 to n do
begin
x[i]:=random(21)-10;
write(x[i],' ');
end;
writeln;
s:=0;
min:=x[1];
for i:=1 to n do
begin
if x[i]<min then min:=x[i];
s:=s+x[i]
end;
writeln('s = ',s:5,' min=',min);
end.