Avdeeva Inga1505
?>

Составить программу, которая формирует массив из 11 случайных целых промежутка [0, 15] и выводит на экран сумму и среднее арифметическое элементов массива

Информатика

Ответы

titov-es3095
Const n=11;
var a:array[1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(16);
 write(a[i],' ');
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('s=',s,'  sr=',s/n:5:2);
end.

Пример работы:
6 12 7 9 3 15 10 10 6 2 8 
s=88  sr= 8.00
vet30
//Dev-C++ 4.9.9.2

#include <iostream>
#include <ctime>
using namespace std;

int main(){
    srand(time(NULL));
    int ma[5][10];
    int maxn=0;
    double s=0;
    double max=-2147483647;
    for(int i=0;i<10;i++)
     for(int j=0;j<5;j++)
      ma[i][j]=rand()%2;
    for(int j=0;j<5;j++){
     for(int i=0;i<10;i++)
      s=s+ma[i][j];
     if(s>max){max=s; maxn=j;}
     s=0;}
    cout<<"Matrix"<<endl;
    for(int i=0;i<10;i++){
     for(int j=0;j<5;j++)
      cout<<ma[i][j]<<" ";
     cout<<endl;}
    cout<<maxn+1;
    cin.get();
    cin.get();
  return 0;
    }

Нужна ! ( программа с++) с датчика случайных чисел заполнить двоичную матрицу 5х10. определить номер
mar77873
Uses GraphABC; 
procedure Draw(x, y, l, u : Real; t : Integer);

procedure Draw2(Var x, y: Real; l, u : Real; t : Integer);
begin
Draw(x, y, l, u, t);
x := x + l*cos(u);
y := y - l*sin(u);end; 
begin
if t > 0 then
beginl := l/3;Draw2(x, y, l, u, t-1);Draw2(x, y, l, u+pi/3, t-1);
Draw2(x, y, l, u-pi/3, t-1);Draw2(x, y, l, u, t-1);end
else
Line(Round(x), Round(y), Round(x+cos(u)*l), Round(y-sin(u)*l))end;
begin
SetWindowSize(425,500);
SetWindowCaption('Фракталы: Снежинка Коха');
Draw(10, 354, 400, pi/3, 4);Draw(410, 354, 400, pi, 4);
Draw(210, 8, 400, -pi/3, 4);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая формирует массив из 11 случайных целых промежутка [0, 15] и выводит на экран сумму и среднее арифметическое элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

andreokiseleo69421
dmdlir
e3913269
alekseysokolov29816
Mikhailovich_Viktoriya
Никита227
gennadevna
svetasvetlana429
kabinet17
d892644813661946
simonovaliubov5852
ivanpetrovichru1801
arammejlumyan
Хабарьева Андрей1056
Ольга1520