петрАфанасьев
?>

Нужно решить в паскале. Три друга принесли конфеты на день рождения учителя. Сколько конфет получит учитель? Формат входных данных: В первых трёх строках даны целые числа - количество конфет, принесённых каждым из учеников. Формат выходных данных: На выход ожидается единственное целое число - количество конфет, которые достанутся учителю.

Информатика

Ответы

saryba

Program Candy;

var One, Two, Three, Sum: integer;

begin

 One := 10;

 Two := 20;

 Three := 30;

 Sum := One + Two + Three;

 writeln('Учитель получит всего ', Sum, ' конфет.');

end.

Sergeevna803

Примечание:

Использовался ЯП Python, версия 3.8.10.

Решение состоит из двух частей: функция которая составляет словарь простых делителей и их степени, и основной код, который отвечает за вызов этой функции и генерацию строки вывода.

В функции prime_factorization использовался достаточно оптимальный алгоритм факторизации.

Код и примеры работы есть в виде скринов.

Исходный код:

def prime_factorization(n):

   d = 2

   divisors = {}

   while n > 1:

       if n % d == 0:

           divisors[d] = divisors.get(d, 0) + 1

           n //= d

       elif d*d > n:

           d = n

       else:

           d += 1

   return divisors

if __name__ == '__main__':

   n = int(input())

   factors = prime_factorization(n)

   s = ' * '.join([f'{k}^{v}' for k, v in sorted(factors.items())])

   print(s)


, на ПИТОНЕ Разложение на простые Требуется разложить целое число N на простые множители с учётом их
, на ПИТОНЕ Разложение на простые Требуется разложить целое число N на простые множители с учётом их
m79857860146895

def solve(n):

 d = 0

 while not (n&1):

   d += 1

   n //= 2

 a = [2]*d

 a[-1] *= n

 if d == 1:

   print("prime")

   return

 for x in range(3, int(n**.5)+1, 2):

   if not (n%x):

     b = a[:]

     b[-1] //= x

     b[-2] *= x

     print("many")

     print(" ".join(map(str, a)))

     print(" ".join(map(str, b)))

     return

 print("single")

 print(" ".join(map(str, a)))

from sys import stdin

for line in stdin:

 print("=== " + line.strip() + " ===")

 solve(int(line))

Дайте плз 5 звёзд, мне очень не хватает "Лучших ответов"

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно решить в паскале. Три друга принесли конфеты на день рождения учителя. Сколько конфет получит учитель? Формат входных данных: В первых трёх строках даны целые числа - количество конфет, принесённых каждым из учеников. Формат выходных данных: На выход ожидается единственное целое число - количество конфет, которые достанутся учителю.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

potapin
vfilina
Pavlov447
MArat
Беспалова
daarisgoy
maksimovskiy7657
Лежачёва355
Коновалова1705
mustaev
natachi
aquilonis
elyashatdinova
borodin
alislisa191