Azarova Anastasiya1707
?>

На пустой шахматной доске в одной из клеток стоит шахматный конь. напишите программу, которая выводит на экран список клеток, которые конь может достичь за один ход из данной клетки. на вход программы с клавиатуры поступают два целых числа х и у через пробел- координаты клетки, где стоит конь (1< =x, y< =8) на паскале написать

Информатика

Ответы

Vladimirovna-Ignatenko1890
Выделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include
void main ()
{
int x, y;
std::cin>>x>>y;
std::cout< std::cout< if (x>1)
std::cout< if (y>1)
std::cout< if (x>2)
std::cout< if (y>2)
std::cout< if (x>2&&y>1)
std::cout< if (y>2&&x>1)
std::cout<}
airon-082054

1 задача:

#include <iostream>

#include <locale>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   for (int i = 0; i < 10; i++)

       cout << "Привет, меня зовут..." << endl;

   return 0;

}


2 задача:

#include <iostream>

#include <locale>

#include <cstdlib>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int num = rand() % (20 - 5 + 1) + 5;

   for (int i = 0; i < num; i++)

       cout << "Привет, меня зовут..." << endl;

   return 0;

}


3 задача:

#include <iostream>

#include <locale>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int num;

   int sum = 0;

   cout << "Введите число: ";

   cin >> num;

   if (num >= 0)

   {

       for (int i = 0; i <= num; i++)

           sum += i;

   }

   else

   {

       for (int i = 0; i >= num; i--)

           sum += i;

   }

   cout << "Сумма = " << sum;

   return 0;

}


1. вывести 10 раз сообщение меня зовут . при цикла. 2. реализовать предыдущую , только количество
1. вывести 10 раз сообщение меня зовут . при цикла. 2. реализовать предыдущую , только количество
1. вывести 10 раз сообщение меня зовут . при цикла. 2. реализовать предыдущую , только количество
keykov35

//Я так понял, что под порядком "неубывания" вы имеете ввиду порядок возрастания...

//Поскольку вы не указали исходный массив, я его сгенерировал, а также вывел на экран, чтобы можно было проверить результаты


const

  size = 10;

  x = -100;

  y = 100;

   

var

  arr: array[1..size] of integer;

  counter, sum, positiveNumbers, negativeNumbers: integer;

  increase: boolean;

   

begin

  randomize;

   

  counter := 0;

  sum := 0;

  positiveNumbers := 0;

  negativeNumbers := 0;

  increase := true;

   

  writeln('Массив:');

   

  for var i := 1 to size do

  begin

     arr[i] := random(x, y);

     writeln(i, ') ', arr[i]);

     

     if (arr[i] > 0) then

     begin

        counter := counter + 1;

        positiveNumbers := positiveNumbers + 1;

        sum := sum + arr[i];      

     end

     

     else

        negativeNumbers := negativeNumbers + 1;

  end;

   

  writeln();

   

  if (counter > 0) then

     writeln('1) Среднее арифметическое всех положительных элементов массива = ', sum / counter)

   

  else

     writeln('1) Положительных элементов массива не было (0)');

     

  if (positiveNumbers > negativeNumbers) then

     writeln('2) В массиве больше положительных элементов')

     

  else if (positiveNumbers = negativeNumbers) then

     writeln('2) В массиве одинаковое количество положительных и отрицательных элементов')

     

  else

     writeln('2) В массиве больше отрицательных элементов');

     

  for var j := 1 to size - 1 do

  begin

     if (arr[j] > arr[j + 1]) then

     begin

        increase := false;

        break;

     end;

  end;

   

  if (increase) then

     writeln('3) Элементы расположены в порядке возрастания')

     

  else

     writeln('3) Элементы не расположены в порядке возрастания');

end.


по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы
по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы
по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На пустой шахматной доске в одной из клеток стоит шахматный конь. напишите программу, которая выводит на экран список клеток, которые конь может достичь за один ход из данной клетки. на вход программы с клавиатуры поступают два целых числа х и у через пробел- координаты клетки, где стоит конь (1< =x, y< =8) на паскале написать
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bykovaam
lazarevaavrora
Ольга тимур
Kolosove5465
aprilsamara2019
sryzhova6392
ltdfoliant62
Plamia7917
beglovatatiyana
dionissia2
Васильевич Валерьевна
Терентьева
nikolai37
mariavayda88734
Lidburg