k-serga1
?>

Написать программу на паскале : ) с процедуры задать матрицу a(n, m) датчиком случайных чисел. определить номера строки и столбца максимального элемента массива.

Информатика

Ответы

sbalashov62
Const n=4; m=5;
type ar=array[1..n,1..m] of integer;
procedure p1(var a:ar);
var i,j:integer;
begin
for i:=1 to n do begin
 for j:=1 to m do begin
   a[i,j]:=random(20)-10;
   write(a[i,j]:4);
  end;
  writeln;
end;
end;
var a:ar; i,j,max,im,jm:integer;
begin
Randomize;
p1(a);
max:=a[1,1]; im:=1; jm:=1;
for i:=1 to n do
 for j:=1 to m do
  if a[i,j]>max then
   begin max:=a[i,j]; im:=i; jm:=j; end;
writeln('max = a[',im,',',jm,'] = ',max);
end.

Пример:
   2  -1  -7   0   7
   3   7  -7  -7   3
  -7  -5  -3  -2   5
   9  -4  -4  -7  -7
max = a[4,1] = 9
ganorussia
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var a:=1 to 10 do begin
    Writeln('Длина стороны ',a,' см');
    for var b:=1 to 10 do
      Writeln('Вторая сторона ',b:2,', периметр ',2*(a+b):2,
          ', площадь ',a*b:3)
    end
end.

Результат
Длина стороны 1 см
Вторая сторона  1, периметр  4, площадь   1
Вторая сторона  2, периметр  6, площадь   2
Вторая сторона  3, периметр  8, площадь   3
Вторая сторона  4, периметр 10, площадь   4
Вторая сторона  5, периметр 12, площадь   5
Вторая сторона  6, периметр 14, площадь   6
Вторая сторона  7, периметр 16, площадь   7
Вторая сторона  8, периметр 18, площадь   8
Вторая сторона  9, периметр 20, площадь   9
Вторая сторона 10, периметр 22, площадь  10
Длина стороны 2 см
Вторая сторона  1, периметр  6, площадь   2
Вторая сторона  2, периметр  8, площадь   4
Вторая сторона  3, периметр 10, площадь   6
Вторая сторона  4, периметр 12, площадь   8
Вторая сторона  5, периметр 14, площадь  10
Вторая сторона  6, периметр 16, площадь  12
Вторая сторона  7, периметр 18, площадь  14
Вторая сторона  8, периметр 20, площадь  16
Вторая сторона  9, периметр 22, площадь  18
Вторая сторона 10, периметр 24, площадь  20
Длина стороны 3 см
Вторая сторона  1, периметр  8, площадь   3
Вторая сторона  2, периметр 10, площадь   6
Вторая сторона  3, периметр 12, площадь   9
Вторая сторона  4, периметр 14, площадь  12

Длина стороны 10 см
Вторая сторона  1, периметр 22, площадь  10
Вторая сторона  2, периметр 24, площадь  20
Вторая сторона  3, периметр 26, площадь  30
Вторая сторона  4, периметр 28, площадь  40
Вторая сторона  5, периметр 30, площадь  50
Вторая сторона  6, периметр 32, площадь  60
Вторая сторона  7, периметр 34, площадь  70
Вторая сторона  8, периметр 36, площадь  80
Вторая сторона  9, периметр 38, площадь  90
Вторая сторона 10, периметр 40, площадь 100
Мария1414

9.Определите значение переменной a после выполнения фрагмента программы:

a:=10;

b:=3;

if a > b then b:=b+12//а больше б, значит к б прибавим 12 и получим что б 21

else a:=a-7;//а это игнорим

if a > b then a:=a+12//теперь а не больше б(б21 а а 10), так что к а прибавим 12, получаем а 22

else a:=a-7;// а это игнорим

А = 22.

11.Определите что будет напечатано в результате работы следующей программы.

Var k,i: integer;

Begin

k :=4;/к равно 4

For i := 1 to 3 do//следующая строка повториться 3 раза, а и при этом будет меняться от 1 до 3

k := 2*k +i;

// При и равном 1 к станет 9

// При и равном 2 к станет 20

// При и равном 3 к станет 43

Writeln(k);// выведет 43

end.

ответ 43

12.Определите что будет напечатано в результате работы следующей программы.

Var s,i: integer;

Begin

s :=3;

For i := 2 to 5 do// и будет меняться от 2 до 5

s := s+2*i

//К с будет прибавляется 2i т.е. сперва 3;7;13;21;31

Writeln(s) ;//31

end

ответ:31

13.Определите что будет напечатано в результате работы следующей программы.

Var s,n: integer;

Begin

s :=1;

For n := 3 to 8 do//повториться 6 раз

s := s*2// каждый раз s увеличивается вдвое, т.е.это 2 в 6 степени

write(s) ;

end.

ответ:64

14.Чему будет равно значение переменной а после выполнения этого цикла?

i:=4;

a:=12;

while i<6 do begin//по сути он повторится 2 раза, а и будет принимать значение от 4 до 5

a:=a+i;//а увеличиваем на и: сперва это 16, потом 21

i:=i+1

end.

ответ:21

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале : ) с процедуры задать матрицу a(n, m) датчиком случайных чисел. определить номера строки и столбца максимального элемента массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

basil69
Pokupatel
mrFuz
nofate1016585
Babushkina27
argent
margo929
dentalfamily
ekkim310
s-shulga
drontox1031
natalia595977
Bologova Golovach1989
MDubovikov73
npprang21