#include <iostream>
unsigned perfectSquareLessOrEqual(unsigned n) {
unsigned sum = 0;
for (unsigned i = 1; (sum + i) <= n; i += 2)
sum += i;
return sum;
}
int main() {
unsigned x, y;
std::cin >> x >> y;
const unsigned a = perfectSquareLessOrEqual(x) + perfectSquareLessOrEqual(y);
const unsigned b = perfectSquareLessOrEqual(x + y);
if (a < b)
std::cout << "Petya gives paint to Vasya";
else if (a > b)
std::cout << "Petya leaves paint to himself";
else
std::cout << "Equal";
return 0;
}
Объяснение:
зарождаются
при работе неверно написанных программных продуктов;
являются
следствием ошибок в операционной системе
создаются
людьми специально для нанесения ущерба ПК
возникают
в связи сбоев в аппаратной части компьютера
Загрузочные вирусы характеризуются
тем, что:
поражают
программы в начале их работы
запускаются
при запуске компьютера
поражают
загрузочные сектора дисков
всегда
меняют начало и длину файла.
Вы хотите оформить предложение
курсивом. Для этого нужно:
поставить
курсор на начало предложения, нажать мышью кнопку Курсив
щелкнуть
мышью слева от предложения, нажать мышью кнопку Курсив
выделить
предложение и нажать сочетание клавиш Ctrl+I
выделить
предложение, используя клавишу Shift
и соответствующую стрелку, нажать мышью кнопку Курсив (Italic)
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая определяет сколько раз в слове повторяется буква.дан текст ''информатика". используя функцию copy
var x, n:integer; byk:char;
const a:string='информатика';
begin
readln(byk);
n:=0;
for x:=0 to 10 do
if Copy(a, x+1, 1)[1]=byk then n:=n+1;
writeln(n);
end.