kulagin777
?>

1.вывести на экран все числа от нуля до введенного пользователем числа. 2.пользователь вводит две границы диапазона. посчитать сумму всех чисел диапазона. 3.написать программу, которая выводит на экран таблицу умножения на k, где k – номер варианта. например, для 7-го варианта: 7 x 2 = 14 7 x 3 = 21 4.найти произведение всех целых чисел от a до 20 (значение a вводится с клавиатуры: 1 < =a < = 20

Информатика

Ответы

борисовна Елена78
1.
int a;
cin >> a;
for (int i = 0; i <= a; ++i)
cout << i << " ";
return 0;

2. int a, int b, res = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i)
res += i;
cout << res;
return 0;

3.
int k;
cin >> k;
for (int i = 1; i < 10; ++i)
cout << k << "x" << i << "=" << k * i;
return 0;

4. int a;
cin >> a;
int res = 1;
for (int i = a; i <= 20; ++i)
res *= a;
cout << a;
return 0;
ntyremsk1

1)

var

  s : real;

  i, n : integer;

begin

  s := 0;

  read (n);

  for i := 1 to n do s := s + 1 / i;

  writeln (s);

end.

 

2)

var

  a, i : integer;

begin

  a := 1;

  for i := 1 to 8 do

  begin

    a := a * 2;

    writeln ('Через ', i * 3, 'часов будет ', a, ' амеб');

  end;

end.

 

3)

var

  n, i : integer;

  x, s : real;

begin

  s := 0;

  read (n, x);

  for i := 1 to n do

    s := s + sin (i * x);

  writeln (s);

end.

 

4)

var

  n, a, r, i : integer;

begin

  r := 1;

  read (a, n);

  for i := 1 to n do r := r * a;

  writeln (r);

end.

Urmanov19903131
Монитор – устройство визуального отображения текстовой и графической информации, преобразует цифровую и (или) аналоговую информацию в видеоизображение.
Стандартный тип мониторов – это мониторы на основе электронно-лучевой трубки (ЭЛТ). Такой монитор по принципу работы ничем не отличается от обычного телевизора: пучок лучей, выбрасываемый электронной пушкой, падает на поверхность кинескопа, покрытую особым веществом – люминофором. Под действием этих каждая точка экрана светится одним из трёх цветов – красным, зелёным и синим. Технология эта старая. обкатанная в течении многих десятилетий, а потому ЭЛТ– мониторы сегодня – совершенные и недорогие устройства. На их стороне – отличная яркость и контрастность изображения, низкая цена, а следовательно, и доступность.Но есть и минусы – вес и габариты ЭЛТ-монитора ну никак не вписываются в сегодняшние представления о компьютере как о миниатюрном устройстве. Прибавьте сюда колоссальное энергопотребление, а также вредное воздействие излучения на пользователя.
Принтеры предназначены для вывода на бумагу (создания “твердой копии”) числовой, текстовой и графической информации. По своему принципу действия принтеры делятся на матричные, струйные и лазерные.
Матричные принтеры – это принтеры ударного действия. Печатающая головка матричного принтера состоит из вертикального столбца маленьких стержней (обычно 9 или 24), которые под воздействием магнитного поля “выталкиваются” из головки и ударяют по бумаге (через красящую ленту). Перемещаясь, печатающая головка оставляет на бумаге строку символов. Недостатки матричных принтеров состоят в том, что они печатают медленно, производят много шума и качество печати оставляет желать лучшего (соответствует примерно качеству пишущей машинки).
Cтруйные принтеры. В последние годы широкое распространение получили черно-белые и цветные струйные принтеры. В них используется чернильная печатающая головка, которая под давлением выбрасывает чернила из ряда мельчайших отверстий на бумагу. Перемещаясь вдоль бумаги, печатающая головка оставляет строку символов или полоску изображения. Струйные принтеры могут печатать достаточно быстро (до нескольких страниц в минуту) и производят мало шума. Качество печати (в том числе и цветной) определяется разрешающей струйных принтеров, которая может достигать фотографического качества 2400 dpi. Это означает, что полоска изображения по горизонтали длиной в 1 дюйм формируется из 2400 точек (чернильных капель).
Лазерные принтеры обеспечивают практически бесшумную печать. Высокую скорость печати (до 30 страниц в минуту) лазерные принтеры достигают за счет постраничной печати, при которой страница печатается сразу целиком. Высокое типографское качество печати лазерных принтеров обеспечивается за счет высокой разрешающей которая может достигать 1200 dpi и более.
Сканер – устройство, которое анализируя какой-либо объект (обычно изображение, текст), создаёт цифровую копию изображения объекта.
Ручные сканеры – обычные или самодвижущиеся – обрабатывают полосы документа шириной около 10 см и представляют интерес, прежде всего для владельцев мобильных ПК. Они медлительны, имеют низкие оптические разрешения (обычно 100 точек на дюйм) и часто сканируют изображения с перекосом. Но зато они недороги и компактны.
Планшетные сканеры более распространены на рынке, чем другие типы сканеров и имеют ряд преимуществ по объему применения, то есть более универсальны. Они напоминают верхнюю часть копировального аппарата: оригинал – либо бумажный документ, либо плоский предмет – кладут на специальное стекло, под которым перемещается каретка с оптикой и аналого-цифровым преобразователем (однако существуют “планшетники”, в которых перемещается стекло с оригиналом, а оптика и АПЦ остаются неподвижными, чем достигается более высокое качество сканирования).
Мышь – устройство управления манипуляторного типа. Перемещение мыши по плоской поверхности синхронизировано с перемещением графического объекта (указателя мыши) на экране монитора. Компьютером управляют перемещением мыши по плоскости и кратковременными нажатиями правой и левой кнопок (Эти нажатия называются щелчками.)
Механические мышки. В механических мышах информация о перемещении курсора формируется с резинового шарика, который касается поверхности стола и вращает два координатных валика – горизонтальный и вертикальный.
Радио-мышки. В настоящее время появились более современные – беспроводные радио-мышки, которые соединяются с системным блоком с радио-датчика (ресивера), подключенного к компьютерному порту.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.вывести на экран все числа от нуля до введенного пользователем числа. 2.пользователь вводит две границы диапазона. посчитать сумму всех чисел диапазона. 3.написать программу, которая выводит на экран таблицу умножения на k, где k – номер варианта. например, для 7-го варианта: 7 x 2 = 14 7 x 3 = 21 4.найти произведение всех целых чисел от a до 20 (значение a вводится с клавиатуры: 1 < =a < = 20
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natalia-shelkovich
papushinrv4985
mos197653
nevasoundmsk36
Палкина-Дроздова
ortopediya
nairahay
jakushkinn
magichands68
ninaandreeva3179
maxchemaxim14
Староческуль-Станиславовна
Aleksandr72
hacker-xx1
festjob