sanina611
?>

Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной.

Информатика

Ответы

eshabunina

#include <iostream>

int main() {

   std::string s;

   int S = 0;

   std::cin >> s;

   for (int i=0; i<s.length(); i++){

       S += int(s[i]-'0');

   }

   std::cout<<(S%2?"Odd":"Even");

   return 0;

}

Объяснение:


Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр вв
Kuzminastia20038
//PascalABC.NET 3.1 сборка 1239
const
    n = 10;
    m = 10;

var
    i, j: integer;
    a, b: array[1..n, 1..m] of integer;
    f: boolean;

begin
    for i := 1 to n do
    begin
        for j := 1 to m do
        begin
            a[i, j] := random(50);
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
    writeln;
    
    for i := 1 to n do
    begin
        f := false;
        for j := 1 to m do
        begin
            if not f and (a[i, j] mod 2 = 1) then begin
                a[i, j] := 2 * a[i, j];
                f := true;
            end;
            write(a[i, j]:3, ' ');
        end;
        writeln;
    end;
end.
Илья_Ветклиники1655

#include <iostream>

#include <vector>

using namespace std;

// глобальные переменные

const int arraySize = 10;

vector <int> numbers;

// сам алгоритм.

void result(){

   

 // совет - обьявляй все переменные в начале функции  

 int leader = 0;

 

 int maxCount = 0;

 int count = 0;

 

 

 // поиск самого частого числа

 for (int c = 0; c < 9;c++){

     // обнуляем счетчик

     count = 0;

     

     for (int c1 = 0;c1 < arraySize;c1++){

         if (numbers[c1] == c) count++;

     }

     

     // проверка на лидера

     if (maxCount < count){

         leader = c;

         maxCount = count;

     }

 }

 

 

 // ну..с посмотрим:

 cout << "Leader: " << leader << " (" << maxCount << ") " << std::endl;

}

int main()

{

   // подготовка масива

   srand(time(NULL)); // обнулем внутрений таймер для полного рандома

   for (int c = 0; c < arraySize;c++) {

       numbers.push_back(rand() % 9); // заполняем масив числами

   }

   // посмотрим на оригинальный масив

   cout << "Original array: ";

   for (int c = 0;c < arraySize;c++) cout << numbers[c] << " ";

   cout << std::endl;

   // сортировка

   result();

   return 0;

}

Объяснение:

Хорошая книга по с++: Герберт Шилд - с++ базовый курс.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мирзоев Денис
АнатольевичМиронова885
soclive7762
vnolenev
fudan
Batishcheva
Aleksandr_Vasilev
stertumasova29
arbat
Vladimirovna-Ignatenko1890
Поліном 2x^4+x^3-7x^2+8x=0
ustinov434
elhovskoemodk
aistenok-28
Karlova1507
▲