Джамал1009
?>

Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например '0', '1', '2' или 'a', 'b', 'c') в которой нет двух смежных идентичных подпоследовательностей. для n=11 последовательность может иметь вид "01020120210".

Информатика

Ответы

АнатольевичМиронова885
#include <iostream>
#include <string>
#include <time.h>
using namespace std;

void main()
 {
srand(time(NULL));
int n,k=0,k1=4;
cin >> n;                         //вводишь количество символов
string *s=new string [n];
for (int i = 0;i < n;++i)
{
while (k == k1)
{
k = rand() % 3;
}
switch (k)
{
case 0:s[i] = '0';cout << s[i];break;
case 1:s[i] ='1';cout << s[i];break;    //вместо 0,1,2 пишешь свой алфавит .
case 2:s[i] ='2';cout << s[i];break;
}
k1 = k;
}
system("pause");
}
slipu817838

1)Черви-сами размножаются и захламляют пк

2)Вирусы-маскировщики — Rootkit. Эти вирусы используются для сокрытия вредоносной активности. Они маскируют вредоносные программы, чтобы избежать их обнаружения

3)Шпионы собирают информацию о действиях и поведении пользователя. В основном их интересует информация — адреса, пароли, данные кредитных карт).

4)Аdware

Программы-рекламы

5)Зомби позволяют злоумышленнику управлять компьютером пользователя

6)Winlock-блокирует виндоус и заставляет заплатить деньги

7)Троян он маскируется в других безвредных программах. В основном трояны используются для кражи, изменения или удаления личных данных пользователя. Он не может самостоятельно размножаться.

Kamil

#include <iostream>

int main() {

  int arr[100], n, first = 0, second = 0;

  std::cin >> n;

  for (int i = 0; i < n; ++i)

      std::cin >> arr[i];

  for (int i = 1; i < n; ++i) {

      const int diff = arr[i] - arr[i - 1];

      if (diff > 0)

          if (arr[i] <= 2000)

              first += diff;

          else if (arr[i - 1] >= 2000)

              second += diff;

          else {

              first += 2000 - arr[i - 1];

              second += arr[i] - 2000;

           }

   }

  std::cout << first << ' ' << second;

  return 0;

Объяснение:

язык python

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например '0', '1', '2' или 'a', 'b', 'c') в которой нет двух смежных идентичных подпоследовательностей. для n=11 последовательность может иметь вид "01020120210".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aa276568
mila010982
мурувватовна викторович569
rigina82
Evagg3856
Annabill1987
Бражинскене_Алексей
asl09777
snopovajulia
Исаченко Тераски1181
Paradismebel
oyunabaduraeva
oafanasiev41
romashka17-90
yana2211
▲