schumacher8
?>

На тему циклы с параметром , а то вообще не понимаю эту тему: ( в некоторых языках программирования, в том числе и в паскале, нет операции возведения в степень. составьте программу возведения некоторого целого числа x в степень y, если числа x и y вводятся с клавиатуры.

Информатика

Ответы

edvlwork15
Почему же нет операции?
я знаю как минимум
1) через формулу  exp(ln(X) * Y)
2) функция  pow(X, Y);

но если у вас тема про циклы, видимо вам надо вручную посчитать степень. тогда опишу вам внутренности функции pow

res:=x;
for i:=2 to y do
res:=res*x;

Вот полностью программа

Var  res,x,i,y: integer;
Begin
writeln('Введите x');
readln(x);

writeln('Введите y');
readln(y);

res:=x;
for i:=2 to y do
res:=res*x;

writeln(res);
readln();
end.
sargisyan77
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
beliaevabeliaeva-olesya35
 другое арбуз почтизнаток  (469) в чем отличие информационных ресурсов от материальных? какие есть основные виды национальных информ. ресурсов? закрыт 5 лет назад в лидеры лучший ответ элявысший разум (175060) это виды:   библиотечные ресурсы  архивные ресурсы  научно-техническая информация  правовая информация  информация государственных (властных) структур  отраслевая информация  финансовая и информация  информация о природных ресурсах  информация предприятий и учреждений  на фоне продолжающегося рос­та производства новых видов товаров начался процесс увеличения доли информационных ресурсов по отношению к материальным. информационные ресурсы в различных формах стали самостоятель­ными объектами (идеи, технологии и ноу-хау, научная и техническая ) [2].  широкое распространение информационных ресурсов дало основание говорить о возникновении информационного общества. информационные ресурсы имеют качественное и принципиальное отличие от материальных, вследствие неприменимости к ним закона сохранения материи. отдавая информационный ресурс, лицо вовсе не лишается его, то есть может использовать его сколько угодно раз.  исследуя и оценивая новые информационные и интеллектуальные ресурсы, современные эконо­мисты, едва успевают их описать и дать некоторые характеристики.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На тему циклы с параметром , а то вообще не понимаю эту тему: ( в некоторых языках программирования, в том числе и в паскале, нет операции возведения в степень. составьте программу возведения некоторого целого числа x в степень y, если числа x и y вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

самир1078
puma802
ВасильевнаСергей
MIKhAILOVNAAnton
MariyaKhanbalaeva585
punctvydachi
Рогова Ольга1156
Valerevna-Vardan
Бочкова_Елена203
ledlenta751
bykotatyana
salesrawtogo
Николаев
verachus
kiruha0378